summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm96
1 files changed, 96 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
new file mode 100644
index 0000000000..215955214c
--- /dev/null
+++ b/gnu/packages/rust-apps.scm
@@ -0,0 +1,96 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rust-apps)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system cargo)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages crates-io))
+
+(define-public ripgrep
+ (package
+ (name "ripgrep")
+ (version "11.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ripgrep" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bn40lz9n08llq615p4qqqbi24zbkf0appfx3zgxg34a86ga9zds"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bstr" ,rust-bstr-0.1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-grep" ,rust-grep-0.2)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-num-cpus" ,rust-num-cpus-1.10)
+ ("rust-regex" ,rust-regex-1.1)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-termcolor" ,rust-termcolor-1.0))
+ #:cargo-development-inputs
+ (("rust-clap" ,rust-clap-2)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0))))
+ (home-page "https://github.com/BurntSushi/ripgrep")
+ (synopsis "Line-oriented search tool")
+ (description
+ "ripgrep is a line-oriented search tool that recursively searches
+your current directory for a regex pattern while respecting your
+gitignore rules.")
+ (license (list license:unlicense license:expat))))
+
+(define-public rust-cbindgen
+ (package
+ (name "rust-cbindgen")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1zgamxahlxmg4warzivaa8m1f8d6b45mhznm7n6d7p5l18acdblx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("clap" ,rust-clap-2)
+ ("log" ,rust-log-0.4)
+ ("proc-macro2" ,rust-proc-macro2-1.0)
+ ("quote" ,rust-quote-1.0)
+ ("serde" ,rust-serde-1.0)
+ ("serde-json" ,rust-serde-json-1.0)
+ ("syn" ,rust-syn-1.0)
+ ("tempfile" ,rust-tempfile-3.0)
+ ("toml" ,rust-toml-0.5))
+ #:cargo-development-inputs
+ (("autocfg" ,rust-autocfg-0.1))))
+ (home-page "https://github.com/eqrion/cbindgen/")
+ (synopsis "Tool for generating C bindings to Rust code")
+ (description
+ "This package provides a tool for generating C/C++ bindings to Rust code.")
+ (license license:mpl2.0)))