summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7e8c8be290..52832eeeb8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
@@ -110,7 +110,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.3
(package
(inherit ruby)
- (version "2.3.7")
+ (version "2.3.8")
(source
(origin
(method url-fetch)
@@ -119,7 +119,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "1nwfaifq5624p1ml56qq5dy5w38z37x22r0qgrbgbzrzklmqy7y6"))
+ "1zhxbjff08pvbnxvn58krns6q0p6g4977q6ykfn823gxhifn63wi"))
(modules '((guix build utils)))
(snippet `(begin
;; Remove bundled libffi
@@ -3010,7 +3010,15 @@ a native C extension.")
(lambda _
;; Regenerate gemspec so loosened dependency constraints are
;; propagated.
- (invoke "rake" "gemspec"))))))
+ (invoke "rake" "gemspec")))
+ (add-after 'regenerate-gemspec 'fix-json-java.gemspec
+ (lambda _
+ ;; This gemspec doesn't look to be generated by the above
+ ;; command, so patch it separately.
+ (substitute* "json-java.gemspec"
+ (("%q<test-unit>\\.freeze, \\[\"~> 2\\.0\"\\]")
+ "%q<test-unit>.freeze, [\">= 2.0\"]"))
+ #t)))))
(native-inputs
`(("bundler" ,bundler)
("ragel" ,ragel)
@@ -3481,7 +3489,7 @@ differences (added or removed nodes) between two XML/HTML documents.")
(define-public ruby-rack
(package
(name "ruby-rack")
- (version "2.0.5")
+ (version "2.0.6")
(source
(origin
(method url-fetch)
@@ -3493,7 +3501,7 @@ differences (added or removed nodes) between two XML/HTML documents.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1k1k4wk10l6bxx46pw58j2p3nmyzjqnr65hbjjqydd6517fmxgib"))
+ "0pb3g5ymvbf07xaxcn51dpqv3djlxavckp3qkxsjdxiqznb0d9p1"))
;; Ignore test which fails inside the build environment but works
;; outside.
(patches (search-patches "ruby-rack-ignore-failing-test.patch"))))