summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm44
1 files changed, 2 insertions, 42 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2080944cae..7e8c8be290 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -194,25 +194,6 @@ a focus on simplicity and productivity.")
(("/bin/sh") (which "sh")))
#t)))))))
-(define-public ruby-concurrent
- (package
- (name "ruby-concurrent")
- (version "1.0.5")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "concurrent-ruby" version))
- (sha256
- (base32
- "183lszf5gx84kcpb779v6a2y0mx9sssy8dgppng1z9a505nj1qcf"))))
- (build-system ruby-build-system)
- (arguments `(#:tests? #f)); No rakefile
- (home-page "https://github.com/ruby-concurrency/concurrent-ruby")
- (synopsis "Concurrency tools for Ruby")
- (description "This gem provides concurrency tools for Ruby. It provides
-a library of common thread-safe types and data-structures as well as abstractions
-for concurrency and communication between threads.")
- (license license:expat)))
-
(define-public ruby-highline
(package
(name "ruby-highline")
@@ -3785,7 +3766,7 @@ A modified copy of yajl is used, and included in the package.")
(define-public ruby-yard
(package
(name "ruby-yard")
- (version "0.9.6")
+ (version "0.9.16")
(source
(origin
(method url-fetch)
@@ -3795,7 +3776,7 @@ A modified copy of yajl is used, and included in the package.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
+ "0sqpbayy9sb406jh0zqg6qha1xds863qz9531dh6vp58hc00clfq"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -5692,27 +5673,6 @@ support the tests found in Prawn, a pure Ruby PDF generation library.")
functionality from Prawn.")
(license license:gpl3+)))
-(define-public ruby-yard
- (package
- (name "ruby-yard")
- (version "0.9.16")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "yard" version))
- (sha256
- (base32
- "0lmmr1839qgbb3zxfa7jf5mzy17yjl1yirwlgzdhws4452gqhn67"))))
- (build-system ruby-build-system)
- (arguments `(#:test-target "spec"))
- (home-page "https://yardoc.org/")
- (synopsis "Ruby documentation tool")
- (description "YARD is a documentation generation tool for the Ruby
-programming language. It enables the user to generate consistent, usable
-documentation that can be exported to a number of formats very easily, and
-also supports extending for custom Ruby constructs such as custom class level
-definitions.")
- (license license:expat)))
-
(define-public ruby-prawn
(package
(name "ruby-prawn")