summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm46
1 files changed, 44 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 42beda3d44..baae553992 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -47,6 +47,7 @@
(define-public ruby
(package
(name "ruby")
+ (replacement ruby-2.3.3)
(version "2.3.1")
(source
(origin
@@ -101,9 +102,28 @@ a focus on simplicity and productivity.")
(home-page "https://ruby-lang.org")
(license license:ruby)))
+(define ruby-2.3.3
+ (package
+ (inherit ruby)
+ (version "2.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
+ (version-major+minor version)
+ "/ruby-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1p0rfk0blrbfjcnv0vb0ha4hxflgkfhv9zbzp4vvld2pi31ahkqs"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ ;; Remove bundled libffi
+ (delete-file-recursively "ext/fiddle/libffi-3.2.1")
+ #t))))))
+
(define-public ruby-2.2
(package (inherit ruby)
- (version "2.2.5")
+ (version "2.2.6")
(source
(origin
(method url-fetch)
@@ -112,7 +132,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "1mw7bzw76g5w37cwhb57r6gxcl2vn9lfrlyf4h4xms3qlnhflvzq"))))))
+ "0fbk2pyjphynj4kxn27vb5rsq6brr3y85p784jd1rxwws30fq54l"))))))
(define-public ruby-2.1
(package (inherit ruby)
@@ -4179,3 +4199,25 @@ patterns.")
libraries for compiling Ruby native extensions.")
(home-page "https://github.com/ruby-gnome2/pkg-config")
(license license:lgpl2.0+)))
+
+(define-public ruby-net-http-digest-auth
+ (package
+ (name "ruby-net-http-digest-auth")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "net-http-digest_auth" version))
+ (sha256
+ (base32
+ "14801gr34g0rmqz9pv4rkfa3crfdbyfk6r48vpg5a5407v0sixqi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis "RFC 2617 HTTP digest authentication library")
+ (description
+ "This library implements HTTP's digest authentication scheme based on
+RFC 2617. This enables the use of the digest authentication scheme instead
+of the more insecure basic authentication scheme.")
+ (home-page "http://github.com/drbrain/net-http-digest_auth")
+ (license license:expat)))