summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index 08501aef6f..bfd30278e9 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -30,7 +30,7 @@
(define-public re2
(package
(name "re2")
- (version "2018-12-01")
+ (version "2019-01-01")
(home-page "https://github.com/google/re2")
(source (origin
(method git-fetch)
@@ -38,7 +38,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "181fq0idwzgfmmpyhmqdxi37rbynzgf1b8s99aaka9kqs9ffwj22"))))
+ "0wys8bbhj8ppgmgp3842qjmnvkynnzxrm8d7c3a3qyq3p6grqa29"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -91,9 +91,9 @@ Python. It is a C++ library.")
;; The tests require the availability of the
;; 'en_US.ISO-8859-1' locale.
(setenv "LOCPATH" (getcwd))
- (zero? (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
+ (invoke "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
(synopsis "Approximate regex matching library and agrep utility")
(description "Superset of the POSIX regex API, enabling approximate
matching. Also ships a version of the agrep utility which behaves similar to