summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index f35d3e63aa..a49fd89bf2 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -85,16 +85,16 @@ Python. It is a C++ library.")
"0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-cons-before
- 'check 'install-locales
- (lambda _
- ;; The tests require the availability of the
- ;; 'en_US.ISO-8859-1' locale.
- (setenv "LOCPATH" (getcwd))
- (zero? (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'install-locales
+ (lambda _
+ ;; The tests require the availability of the
+ ;; 'en_US.ISO-8859-1' locale.
+ (setenv "LOCPATH" (getcwd))
+ (zero? (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
(synopsis "Approximate regex matching library and agrep utility")
(description "Superset of the POSIX regex API, enabling approximate
matching. Also ships a version of the agrep utility which behaves similar to