summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm119
1 files changed, 119 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index a84a31fd9c..8f1562a176 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages documentation)
#:use-module (gnu packages engineering)
+ #:use-module (gnu packages fltk)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gstreamer)
@@ -525,3 +526,121 @@ to the fix block above.
using GNU Radio and the Qt GUI toolkit.")
(home-page "https://gqrx.dk/")
(license license:gpl3+)))
+
+(define-public fldigi
+ (package
+ (name "fldigi")
+ (version "4.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.w1hkj.com/files/fldigi/fldigi-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1y62xn1pim38ibaf2mbl8b7aq20jdaac6lgggb9r402w9bj5b196"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("fltk" ,fltk)
+ ("libpng" ,libpng)
+ ("libsamplerate" ,libsamplerate)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)
+ ("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)))
+ (synopsis "Software modem for amateur radio use")
+ (description
+ "Fldigi is a software modem for amateur radio use. It is a sound card
+based program that is used for both transmitting and receiving data by
+connecting the microphone and headphone connections of a computer to some radio
+hardware.")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))
+
+(define-public flrig
+ (package
+ (name "flrig")
+ (version "1.3.50")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.w1hkj.com/files/flrig/flrig-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0fzrknzzi8kmzmrcfpc8rxr7v4a4ny6z6z5q5qwh95sp2kn2qzp9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fltk" ,fltk)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)))
+ (synopsis "Radio transceiver control program")
+ (description
+ "Flrig is a transceiver control program for amateur radio use.
+It provides computer aided control of various radios using a serial
+or USB connection.")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))
+
+(define-public flamp
+ (package
+ (name "flamp")
+ (version "2.2.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.w1hkj.com/files/flamp/flamp-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "19z1kghhdf7bq6hi2j0mzlsn2nhpn3gl1a623x3inmsk80yw3ck4"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fltk" ,fltk)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)))
+ (synopsis "Tool for AMP file transfer")
+ (description
+ "FLAMP is a program for transfering files by radio waves using AMP
+(Amateur Multicast Protocol).")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))
+
+(define-public flwrap
+ (package
+ (name "flwrap")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.w1hkj.com/files/flwrap/flwrap-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0qqivqkkravcg7j45740xfky2q3k7czqpkj6y364qff424q2pppg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fltk" ,fltk)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)))
+ (synopsis "File encapsulation program")
+ (description
+ "Flwrap is a software utility for amateur radio use. Its purpose is to
+encapsulate both text and binary files in a way that allows them to be
+transmitted over any of several digital modes and verified at the receipt end
+for correctness.")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))