summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 2eb0a82415..cbfb068e3c 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -915,6 +915,17 @@ weak-signal conditions.")
(assoc-ref outputs "out")
"/share")))
#t))
+ (add-after 'fix-paths 'work-around-runtime-bug
+ (lambda _
+ ;; Some of the programs in this package fail to find symbols
+ ;; in libm at runtime. Adding libm manually at the end of the
+ ;; library lists when linking the programs seems to help.
+ ;; TODO: find exactly what is wrong in the way the programs
+ ;; are built.
+ (substitute* "CMakeLists.txt"
+ (("target_link_libraries \\((.*)\\)" all libs)
+ (string-append "target_link_libraries (" libs " m)")))
+ #t))
(add-after 'unpack 'fix-hamlib
(lambda _
(substitute* "CMake/Modules/Findhamlib.cmake"