summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index eca60bc251..ec56c8593f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6644,7 +6644,13 @@ that have uses outside of the Zope framework.")
"/zope.testing/zope.testing-" version ".tar.gz"))
(sha256
(base32
- "1yvglxhzvhl45mndvn9gskx2ph30zz1bz7rrlyfs62fv2pvih90s"))))
+ "1yvglxhzvhl45mndvn9gskx2ph30zz1bz7rrlyfs62fv2pvih90s"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-compiled .pyc files backup files from source.
+ (for-each delete-file (find-files "." "(\\.pyc|~)$"))
+ #t))))
(build-system python-build-system)
(native-inputs
`(("python-zope-exceptions" ,python-zope-exceptions)))