summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm137
1 files changed, 134 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b93ab5ee78..c328e9bd15 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
@@ -35,6 +35,7 @@
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1064,14 +1065,14 @@ Python file, so it can be easily copied into your project.")
(define-public python-dateutil-2
(package
(name "python-dateutil")
- (version "2.5.2")
+ (version "2.5.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-dateutil" version))
(sha256
(base32
- "0jrfpcgvgya6hs45dhrd9yiqgdgz9qp9aa07zsw8gqgn8zphff86"))))
+ "1v9j9fmf8g911yg6k01xa2db6dx3wv73zkk7fncsj7vagjqgs20l"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
@@ -5993,6 +5994,28 @@ complexity of Python source code.")
(define-public python2-flake8-2.2.4
(package-with-python2 python-flake8-2.2.4))
+(define-public python-flake8-polyfill
+ (package
+ (name "python-flake8-polyfill")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-polyfill" version))
+ (sha256
+ (base32
+ "02gn2wxvh9vnf7m7dld7ca4l60mg5c370hv3swwppkngwaqmcw67"))))
+ (build-system python-build-system)
+ (home-page "https://gitlab.com/pycqa/flake8-polyfill")
+ (synopsis "Polyfill package for Flake8 plugins")
+ (description
+ "This package that provides some compatibility helpers for Flake8
+plugins that intend to support Flake8 2.x and 3.x simultaneously.")
+ (license license:expat)))
+
+(define-public python2-flake8-polyfill
+ (package-with-python2 python-flake8-polyfill))
+
(define-public python-mistune
(package
(name "python-mistune")
@@ -12537,3 +12560,111 @@ console.")
This implementation is slow (hence the project name) but still useful when
faster ones are not available.")
(license license:asl2.0)))
+
+(define-public python-rst2ansi
+ (package
+ (name "python-rst2ansi")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rst2ansi" version))
+ (sha256
+ (base32
+ "0vzy6gd60l79ff750scl0sz48r1laalkl6md6dwzah4dcadgn5qv"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)))
+ (home-page "https://github.com/Snaipe/python-rst-to-ansi")
+ (synopsis "Convert RST to ANSI-decorated console output")
+ (description
+ "Python module dedicated to rendering RST (reStructuredText) documents
+to ansi-escaped strings suitable for display in a terminal.")
+ (license license:expat)))
+
+(define-public python-ddt
+ (package
+ (name "python-ddt")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ddt" version))
+ (sha256
+ (base32
+ "1c00ikkxr7lha97c81k938bzhgd4pbwamkjn0h4nkhr3xk00zp6n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/txels/ddt")
+ (synopsis "Data-Driven Tests")
+ (description
+ "DDT (Data-Driven Tests) allows you to multiply one test case by running
+it with different test data, and make it appear as multiple test cases.")
+ (license license:expat)))
+
+(define-public python2-ddt
+ (package-with-python2 python-ddt))
+
+(define-public python-pycosat
+ (package
+ (name "python-pycosat")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycosat" version))
+ (sha256
+ (base32
+ "1kl3wh1f47rc712n4bmwplbx3fqz3x9i1b587jrbpmvdva4c8f6l"))))
+ ;; TODO: Unundle picosat. http://fmv.jku.at/picosat/
+ (build-system python-build-system)
+ (home-page "https://github.com/ContinuumIO/pycosat")
+ (synopsis "Bindings to picosat (a SAT solver)")
+ (description
+ "This package provides efficient Python bindings to @code{picosat} on
+the C level. When importing pycosat, the @code{picosat} solver becomes part
+of the Python process itself. @code{picosat} is a @dfn{Boolean Satisfiability
+Problem} (SAT) solver.")
+ (license license:expat)))
+
+(define-public python2-pycosat
+ (package-with-python2 python-pycosat))
+
+(define-public python2-ruamel.ordereddict
+ (package
+ (name "python2-ruamel.ordereddict")
+ (version "0.4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruamel.ordereddict" version))
+ (sha256
+ (base32
+ "1xmkl8v9l9inm2pyxgc1fm5005yxm7fkd5gv74q7lj1iy5qc8n3h"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "python" "test/testordereddict.py")))))))
+ (home-page "https://bitbucket.org/ruamel/ordereddict")
+ (synopsis "Version of dict that keeps keys in insertion order")
+ (description
+ "This is an implementation of an ordered dictionary with @dfn{Key
+Insertion Order} (KIO: updates of values do not affect the position of the
+key), @dfn{Key Value Insertion Order} (KVIO, an existing key's position is
+removed and put at the back). The standard library module @code{OrderedDict},
+implemented later, implements a subset of @code{ordereddict} functionality.
+Sorted dictionaries are also provided. Currently only with @dfn{Key Sorted
+Order} (KSO, no sorting function can be specified, but a transform can be
+specified to apply on the key before comparison (e.g. @code{string.lower})).")
+ (license license:expat)))