aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm60
1 files changed, 53 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8cd433a93d..164c1f49bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
+;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5522,6 +5523,17 @@ features useful for text console applications.")
(base32
"1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "./admin/runtests")))))))
+ (propagated-inputs
+ `(("python-defusedxml" ,python-defusedxml)))
+ (native-inputs
+ `(("python-psycopg2" ,python-psycopg2)
+ ("python-django" ,python-django)))
(home-page "https://github.com/necaris/python3-openid")
(synopsis "OpenID support for servers and consumers")
(description "This library provides OpenID authentication for Python, both
@@ -6786,7 +6798,7 @@ should be stored on various operating systems.")
(define-public python-llfuse
(package
(name "python-llfuse")
- (version "1.1.1")
+ (version "1.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -6794,7 +6806,7 @@ should be stored on various operating systems.")
"llfuse-" version ".tar.bz2"))
(sha256
(base32
- "0v6vj9mb286njgd1szg9hz2qdh5f3vkhsvajripfcqg458av310v"))))
+ "11hms1x68bf1bqbqy7w3wpffqsd3jkgricmzrc1hrnwkswfzzlr4"))))
(build-system python-build-system)
(inputs
`(("fuse" ,fuse)
@@ -7322,14 +7334,14 @@ message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "16.2.0")
+ (version "17.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyOpenSSL" version))
(sha256
(base32
- "0vji4yrfshs15xpczbhzhasnjrwcarsqg87n98ixnyafnyxs6ybp"))
+ "1pdg1gpmkzj8yasg6cmkhcivxcdp4c12nif88y4qvsxq5ffzxas8"))
(patches
(search-patches "python-pyopenssl-skip-network-test.patch"))))
(build-system python-build-system)
@@ -7347,7 +7359,7 @@ message digests and key derivation functions.")
(inputs
`(("openssl" ,openssl)))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest-3.0)))
(home-page "https://github.com/pyca/pyopenssl")
(synopsis "Python wrapper module around the OpenSSL library")
(description
@@ -9372,6 +9384,7 @@ interface to the Amazon Web Services (AWS) API.")
("python-botocore" ,python-botocore)
("python-s3transfer" ,python-s3transfer)
("python-docutils" ,python-docutils)
+ ("python-pyyaml" ,python-pyyaml)
("python-rsa" ,python-rsa)))
(arguments
;; FIXME: The 'pypi' release does not contain tests.
@@ -10020,13 +10033,13 @@ programmatically interfacing with your system's $EDITOR.")
(define-public python-sphinxcontrib-programoutput
(package
(name "python-sphinxcontrib-programoutput")
- (version "0.8")
+ (version "0.10")
(source (origin
(method url-fetch)
(uri (pypi-uri "sphinxcontrib-programoutput" version))
(sha256
(base32
- "098as6z1s0gb4dh5xcr1fd2vpm91zj93jzvgawspxf5s4hqs0xhp"))))
+ "153hhnlbx4688zj9wd64819ps5znc2jlyp5crkgzvn5hxgy99vpx"))))
(build-system python-build-system)
(arguments
;; FIXME: Many tests are failing and the upstream is gone.
@@ -13965,3 +13978,36 @@ recognize TestCases.")
(sha256
(base32
"17jlkdpqw22z1nyml5ybslilqkzmnk0dxxjml8bfghav1l5hbwd2"))))))
+
+(define-public python-fudge
+ (package
+ (name "python-fudge")
+ ;; 0.9.6 is the latest version suitable for testing the "fabric" Python 2
+ ;; package, which is currently the only use of this package.
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fudge" version))
+ (sha256
+ (base32
+ "185ia3vr3qk4f2s1a9hdxb8ci4qc0x0xidrad96pywg8j930qs9l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;XXX: Tests require the NoseJS Python package.
+ (home-page "https://github.com/fudge-py/fudge")
+ (synopsis "Replace real objects with fakes/mocks/stubs while testing")
+ (description
+ "Fudge is a Python module for using fake objects (mocks and stubs) to
+test real ones.
+
+In readable Python code, you declare the methods available on your fake object
+and how they should be called. Then you inject that into your application and
+start testing. This declarative approach means you don’t have to record and
+playback actions and you don’t have to inspect your fakes after running code.
+If the fake object was used incorrectly then you’ll see an informative
+exception message with a traceback that points to the culprit.")
+ (license license:expat)))
+
+(define-public python2-fudge
+ (package-with-python2 python-fudge))