summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm135
1 files changed, 119 insertions, 16 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 00c9917392..93bfe18526 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1840,7 +1840,7 @@ standard library.")
(define-public python2-unittest2
(package (inherit python-unittest2)
(name "python2-unittest2")
- (version "0.5.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -1849,7 +1849,12 @@ standard library.")
version ".tar.gz"))
(sha256
(base32
- "0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
+ "0y855kmx7a8rnf81d3lh5lyxai1908xjp0laf4glwa4c8472m212"))
+ (patches
+ (search-patches "python2-unittest2-remove-argparse.patch"))))
+ (propagated-inputs
+ `(("python2-six" ,python2-six)
+ ("python2-traceback2" ,python2-traceback2)))
(arguments
`(#:python ,python-2
#:tests? #f)))) ; no setup.py test command
@@ -3387,6 +3392,30 @@ sources.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+(define-public python-guzzle-sphinx-theme
+ (package
+ (name "python-guzzle-sphinx-theme")
+ (version "0.7.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "guzzle_sphinx_theme" version))
+ (sha256
+ (base32
+ "1rnkzrrsbnifn3vsb4pfaia3nlvgvw6ndpxp7lzjrh23qcwid34v"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/guzzle/guzzle_sphinx_theme")
+ (synopsis "Sphinx theme used by Guzzle")
+ (description "This package provides guzzle_sphinx_theme, a theme for the
+Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
+and several other projects.")
+ (license license:expat)))
+
+(define-public python2-guzzle-sphinx-theme
+ (package-with-python2 python-guzzle-sphinx-theme))
+
(define-public python-rst.linker
(package
(name "python-rst.linker")
@@ -4899,20 +4928,21 @@ You might also want to install the following optional dependencies:
(define-public python-alembic
(package
(name "python-alembic")
- (version "0.8.10")
+ (version "0.9.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "alembic" version))
(sha256
(base32
- "06br9sfqypnjlal6fsbnky3zb0askwcn3diz8k3kwa0qcblm0fqf"))))
+ "01gx2syqbaxh4hr9pf7pxhlb6p36qaf99140dy19lsx1paxb9p4b"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
("python-pytest-cov" ,python-pytest-cov)))
(propagated-inputs
- `(("python-sqlalchemy" ,python-sqlalchemy)
+ `(("python-dateutil" ,python-dateutil)
+ ("python-sqlalchemy" ,python-sqlalchemy)
("python-mako" ,python-mako)
("python-editor" ,python-editor)))
(home-page "http://bitbucket.org/zzzeek/alembic")
@@ -7542,10 +7572,7 @@ reading and writing MessagePack data.")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/n/netaddr/netaddr-"
- version
- ".tar.gz"))
+ (uri (pypi-uri "netaddr" version))
(sha256
(base32
"1zdfadvpq4lmcqzr383gywxn4xyn355kj1n3lk9q2l03vmyfrbiq"))))
@@ -11491,8 +11518,21 @@ to occurrences in strings and comments.")
(base32
"0i283z1pivmir61z8kbiycigc94l61v33ygzkhczf1ifq7cppyds"))))
(build-system python-build-system)
+ (inputs
+ `(("file" ,file)))
(arguments
- '(#:tests? #f)) ; TODO: Requires many libraries not in Guix.
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; 'file' is used for detection of configuration file encoding
+ ;; let's make link the dependency to particular input
+ (add-before 'build 'patch-file-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file-path (assoc-ref inputs "file")))
+ (substitute* "py3status/parse_config.py"
+ (("check_output\\(\\['file'")
+ (string-append "check_output(['" file-path "/bin/file'")))
+ #t))))
+ #:tests? #f)) ; TODO: Requires many libraries not in Guix.
(home-page "https://github.com/ultrabug/py3status")
(synopsis "Extensible i3status wrapper written in Python")
(description "py3status is an i3status wrapper which extends i3status
@@ -11936,13 +11976,13 @@ objects, patterned after the Mocha library for Ruby.")
(define-public python-arrow
(package
(name "python-arrow")
- (version "0.8.0")
+ (version "0.10.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "arrow" version))
(sha256
(base32
- "1bz7hkdgpqcjs866y58z8jywpy7al0f4rxdr00bh2l5qddyw245j"))))
+ "08n7q2l69hlainds1byd4lxhwrq7zsw7s640zkqc3bs5jkq0cnc0"))))
(build-system python-build-system)
(native-inputs
`(;; For testing
@@ -13423,14 +13463,14 @@ useful as a validator for JSON data.")
(define-public python-aniso8601
(package
(name "python-aniso8601")
- (version "1.1.0")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aniso8601" version))
(sha256
(base32
- "1k5mjg9iqbjfslb5prrsfz7dhlvi6s35p1jxq8dm87w1b7dn5i2g"))))
+ "1waj54iv3n3lw1fapbz8a93yjgrybgpc86wif5baxdh1arpj9df3"))))
(build-system python-build-system)
(propagated-inputs
`(("python-dateutil" ,python-dateutil)))
@@ -13442,6 +13482,9 @@ useful as a validator for JSON data.")
"This package contains a library for parsing ISO 8601 datetime strings.")
(license license:bsd-3)))
+(define-public python2-aniso8601
+ (package-with-python2 python-aniso8601))
+
(define-public python-flask-restful
(package
(name "python-flask-restful")
@@ -15911,14 +15954,14 @@ complex datatypes to and from native Python datatypes.")
(define-public python-apispec
(package
(name "python-apispec")
- (version "0.22.0")
+ (version "0.25.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "apispec" version))
(sha256
(base32
- "0y3jxmgp2d24am3hxl40f5rw9abb0r8037sagax3dv64h4n1azwq"))))
+ "0kxa8723zbisx10363yh4mmmn4higxrspymbjfz5zq8f644zagm9"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pyyaml" ,python-pyyaml)))
@@ -16462,3 +16505,63 @@ their files and supports any packaging format (including wheels).")
(define-public python2-twine
(package-with-python2 python-twine))
+
+(define-public python-linecache2
+ (package
+ (name "python-linecache2")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "linecache2" version))
+ (sha256
+ (base32
+ "0z79g3ds5wk2lvnqw0y2jpakjf32h95bd9zmnvp7dnqhf57gy9jb"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; The tests depend on unittest2, and our version is a bit too old.
+ #:tests? #f))
+ (native-inputs
+ `(("python-pbr" ,python-pbr)))
+ (home-page
+ "https://github.com/testing-cabal/linecache2")
+ (synopsis "Backports of the linecache module")
+ (description
+ "The linecache module allows one to get any line from any file, while
+attempting to optimize internally, using a cache, the common case where many
+lines are read from a single file.")
+ (license license:psfl)))
+
+(define-public python2-linecache2
+ (package-with-python2 python-linecache2))
+
+(define-public python-traceback2
+ (package
+ (name "python-traceback2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "traceback2" version))
+ (sha256
+ (base32
+ "0c1h3jas1jp1fdbn9z2mrgn3jj0hw1x3yhnkxp7jw34q15xcdb05"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; python-traceback2 and python-unittest2 depend on one another.
+ #:tests? #f))
+ (native-inputs
+ `(("python-pbr" ,python-pbr)))
+ (propagated-inputs
+ `(("python-linecache2" ,python-linecache2)))
+ (home-page
+ "https://github.com/testing-cabal/traceback2")
+ (synopsis "Backports of the traceback module")
+ (description
+ "This module provides a standard interface to extract, format and print
+stack traces of Python programs. It exactly mimics the behavior of the Python
+interpreter when it prints a stack trace.")
+ (license license:psfl)))
+
+(define-public python2-traceback2
+ (package-with-python2 python-traceback2))