summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2e74d773f..10d3d59664 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10729,19 +10729,22 @@ and bit flag values.")
(define-public python-attrs
(package
(name "python-attrs")
- (version "17.2.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "attrs" version))
- (sha256
- (base32
- "04gx08ikpk26wnq22f7l42gapcvk8iz1512r927k6sadz6cinkax"))))
+ (version "17.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "attrs" version))
+ (sha256
+ (base32
+ "1jafnn1kzd6qhxgprhx6y6ik1r5m2rilx25syzcmq03azp660y8w"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)
+ `(("python-coverage" ,python-coverage)
("python-hypothesis" ,python-hypothesis)
- ("python-zope-interface" ,python-zope-interface)
- ("python-six" ,python-six)))
+ ("python-pytest" ,python-pytest)
+ ("python-six" ,python-six)
+ ("python-sphinx" ,python-sphinx)
+ ("python-zope-interface" ,python-zope-interface)))
(home-page "https://github.com/python-attrs/attrs/")
(synopsis "Attributes without boilerplate")
(description "@code{attrs} is a Python package with class decorators that