summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm71
1 files changed, 59 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 102b69cae6..6fe83b2a8b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -806,14 +806,14 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(define-public python-h5py
(package
(name "python-h5py")
- (version "2.6.0")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h5py" version))
(sha256
(base32
- "0df46dg7i7xfking9lp221bfm8dbl974yvlrbi1w7r6m61ac7bxj"))))
+ "0433sdv6xc9p7v1xs1gvbxp7p152ywi3nplgjb258q9fvw9469br"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -855,14 +855,14 @@ concepts.")
(define-public python-netcdf4
(package
(name "python-netcdf4")
- (version "1.2.7")
+ (version "1.2.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "netCDF4" version))
(sha256
(base32
- "1fllizmnpw0zkzzm4j9pgamarlzfn3kmv9zrm0w65q1y31h9ni0c"))))
+ "1h6jq338amlbk0ilzvjyl7cck80i0bah9a5spn9in71vy2qxm7i5"))))
(build-system python-build-system)
(native-inputs
`(("python-cython" ,python-cython)))
@@ -3477,7 +3477,7 @@ and is very extensible.")
(define-public python-scikit-learn
(package
(name "python-scikit-learn")
- (version "0.18.1")
+ (version "0.19.0")
(source
(origin
(method url-fetch)
@@ -3487,7 +3487,7 @@ and is very extensible.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1hwswckdmd27f7k1jvwdc0m4mqrgxl2s245yq1scq34v124bjqgq"))))
+ "0g7q4ri75mj93wpa9bp83a3jmrf3dm5va9h7k4zkbcxr6bgqka15"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5230,6 +5230,53 @@ cluster without needing to write any wrapper code yourself.")
(define-public python2-gridmap
(package-with-python2 python-gridmap))
+(define-public python-honcho
+ (package
+ (name "python-honcho")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nickstenning/honcho/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0zizn61n5z5hq421hkypk9pw8s6fpxw30f4hsg7k4ivwzy3gjw9j"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest-3.0)
+ ("python-mock" ,python-mock)
+ ("python-tox" ,python-tox)
+ ("which" ,which))) ;for tests
+ (propagated-inputs
+ `(("python-jinja2" ,python-jinja2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; fix honcho path in testsuite
+ (substitute* "tests/conftest.py"
+ (("'honcho'") (string-append "'" (assoc-ref outputs "out")
+ "/bin/honcho" "'")))
+ ;; It's easier to run tests after install.
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "py.test" "-v")))))))
+ (home-page "https://github.com/nickstenning/honcho")
+ (synopsis "Manage Procfile-based applications")
+ (description
+ "A Procfile is a file which describes how to run an application
+consisting of serveral processes. honcho starts all listed processes.
+The output of all running processes is collected by honcho and
+displayed.")
+ (license license:expat)))
+
+(define-public python2-honcho
+ (package-with-python2 python-honcho))
+
(define-public python-pexpect
(package
(name "python-pexpect")
@@ -13932,7 +13979,7 @@ parse many formal languages.")
(define-public python2-cliapp
(package
(name "python2-cliapp")
- (version "1.20160724")
+ (version "1.20170823")
(source
(origin
(method url-fetch)
@@ -13941,7 +13988,7 @@ parse many formal languages.")
version ".tar.gz"))
(sha256
(base32
- "025cyi75vxyghbm4hav8dz4fzwksshddavy9g9fwr440awcvw74f"))))
+ "1i9gik0xrj6jmi95s5w988jl1y265baz5xm5pbqdyvsh8h9ln6yq"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2))
@@ -13958,7 +14005,7 @@ iterating over input files.")
(define-public python2-ttystatus
(package
(name "python2-ttystatus")
- (version "0.32")
+ (version "0.35")
(source
(origin
(method url-fetch)
@@ -13967,7 +14014,7 @@ iterating over input files.")
version ".tar.gz"))
(sha256
(base32
- "0b5g889jj23r2w1hi300cdldx6jvspanp0ybf5n1qvdvl150aamf"))))
+ "0vivqbw7ddhsq1zj3g9cvvv4f0phl0pis2smsnwcr2szz2fk3hl6"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2))
@@ -15566,14 +15613,14 @@ address is valid and really exists.")
(define-public python-marshmallow
(package
(name "python-marshmallow")
- (version "3.0.0b2")
+ (version "3.0.0b3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "marshmallow" version))
(sha256
(base32
- "11bnpvfdbczr74177p295zbkdrax2cahvbj5bqhhlprgz2xxi5d9"))))
+ "07mcrij1yvk85lvgx44wwr9pc80xryghvlgayb057g1cazcypysd"))))
(build-system python-build-system)
(propagated-inputs
`(("python-dateutil" ,python-dateutil)