aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a41e81c66..c951d6a78b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6630,14 +6630,14 @@ responses, rather than doing any computation.")
(define-public python-pip
(package
(name "python-pip")
- (version "9.0.1")
+ (version "18.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pip" version))
(sha256
(base32
- "03clr9c1dih5n9c00c592zzvf6r1ffimywkaq9agcqdllzhl7wh9"))))
+ "188fclay154s520n43s7cxxlhdaiysvxf19zk8vr1xbyjyyr58n0"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; there are no tests in the pypi archive.
@@ -13936,14 +13936,14 @@ generators and Python 3.7's context managers into Python 3.5.")
(define-public python-async-timeout
(package
(name "python-async-timeout")
- (version "2.0.1")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "async-timeout" version))
(sha256
(base32
- "1l3kg062m02mph6rf9rdv8r5c5n356clxa6b6mrn0i77vk9g9kq0"))))
+ "0pscbyr840m7fyfc3r8zv9kgkwdcn9f78p7zsrczciwd09m82g0c"))))
(build-system python-build-system)
(home-page "https://github.com/aio-libs/async_timeout/")
(synopsis "Timeout context manager for asyncio programs")
@@ -14793,3 +14793,21 @@ RFC 8265 and RFC 8266.")
@url{https://www.wikidata.org/, Wikidata}.")
(properties '((upstream-name . "Wikidata")))
(license license:gpl3+)))
+
+(define-public python-attr
+ (package
+ (name "python-attr")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "attr" version))
+ (sha256
+ (base32
+ "0pbpskvxp5hzdvcaf766ljwpckshir8sf7z6jqji6zyib20594ch"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/denis-ryzhkov/attr")
+ (synopsis "Decorator for attributes of target function or class")
+ (description "Simple decorator to set attributes of target function or
+class in a @acronym{DRY, Don't Repeat Yourself} way.")
+ (license license:expat)))