summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 038237d6fd..96589fc165 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2154,10 +2154,11 @@ executed.")
(description
"This is a library package for use by pytest-cov, nose-cov and nose2-cov.
It is useful for developing coverage plugins for these testing frameworks.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-cov-core))))))
(define-public python2-cov-core
- (let ((cov-core (package-with-python2 python-cov-core)))
+ (let ((cov-core (package-with-python2 (strip-python2-variant python-cov-core))))
(package (inherit cov-core)
(native-inputs
`(("python2-setuptools" ,python2-setuptools)