summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 940efeca64..b588dd649a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2784,7 +2784,7 @@ association studies (GWAS) on extremely large data sets.")
(tgt-dir (string-append html "/" dir)))
(unless (equal? "." dir)
(mkdir-p tgt-dir))
- (copy-file file (string-append html "/" file))))
+ (install-file file html)))
(find-files "." ".*"))))))
,phases)))))))
@@ -2828,7 +2828,7 @@ association studies (GWAS) on extremely large data sets.")
(for-each
(lambda (dir tgt)
(map (lambda (file)
- (copy-file file (string-append tgt "/" (basename file))))
+ (install-file file tgt))
(find-files dir ".*")))
(list "docs" "htmldoc" "examples")
(list doc html-doc examples))))
@@ -3140,9 +3140,7 @@ atlas_libs = openblas
(for-each (lambda (file)
(let* ((dir (dirname file))
(tgt-dir (string-append html "/" dir)))
- (unless (equal? "." dir)
- (mkdir-p tgt-dir))
- (copy-file file (string-append html "/" file))))
+ (install-file file html)))
(find-files "." ".*"))))))
;; Tests can only be run after the library has been installed and not
;; within the source directory.