summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88ab4427e1..a3802a42e0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,35 @@ pidof, tty, taskset, pmap.")
(define-public python2-psutil
(package-with-python2 python-psutil))
+(define-public python-ccm
+ (package
+ (name "python-ccm")
+ (version "2.0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/c/ccm/ccm-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "199jw221albs2iv6xczczq88fxnh0aw8hzmys8qkbzkd99dssng9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("python-pyyaml" ,python-pyyaml)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/pcmanus/ccm")
+ (synopsis "Cassandra Cluster Manager")
+ (description "A script/library to create, launch and remove an Apache
+Cassandra cluster on localhost.")
+ (license asl2.0)))
+
+(define-public python2-ccm
+ (package-with-python2 python-ccm))
+
(define-public python-pytz
(package
(name "python-pytz")