aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm135
1 files changed, 31 insertions, 104 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 992a750911..d2b348942d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -105,6 +106,7 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages monitoring)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages networking)
#:use-module (gnu packages ncurses)
@@ -444,12 +446,23 @@ concepts.")
(base32
"1z2hx357xp3v4cv44xmqp7lli3frndqpyfmpbxf7n76h7s1zaaxm"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "sh.py" "test"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)))
(home-page "https://github.com/amoffat/sh")
(synopsis "Python subprocess replacement")
(description "This package provides a replacement for Python's
@code{subprocess} feature.")
(license license:expat)))
+(define-public python2-sh
+ (package-with-python2 python-sh))
+
(define-public python-cftime
(package
(name "python-cftime")
@@ -1683,14 +1696,14 @@ with sensible defaults out of the box.")
(define-public python-wheel
(package
(name "python-wheel")
- (version "0.30.0a0")
+ (version "0.32.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wheel" version))
(sha256
(base32
- "1nm6mn8isny0hr86rhbfrpfj867c0phf001xgsd69xfp9ady1wwq"))))
+ "1dhxl1bf18bx9szmqcnxbg6204hp3im8089q3hkwh5jfa6zh75q2"))))
(build-system python-build-system)
(native-inputs
`(("python-jsonschema" ,python-jsonschema)
@@ -4505,28 +4518,6 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python2-ipykernel
(package-with-python2 python-ipykernel))
-(define-public python-send2trash
- (package
- (name "python-send2trash")
- (version "1.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "send2trash" version))
- (sha256
- (base32
- "1ci8vcwjmjlp11ljj1ckrfmml9fkq1mclx2gr53y4zvhgp01q030"))))
- (build-system python-build-system)
- (home-page "https://github.com/hsoft/send2trash")
- (synopsis "Send files to trash")
- (description
- "This package provides a cross-platform mechanism to send files to the
-trash.")
- (license license:bsd-3)))
-
-(define-public python2-send2trash
- (package-with-python2 python-send2trash))
-
;; This is the latest release of the LTS version of ipython with support for
;; Python 2.7 and Python 3.x. Later non-LTS versions starting from 6.0 have
;; dropped support for Python 2.7. We may want to rename this package.
@@ -6732,31 +6723,6 @@ convert an @code{.ipynb} notebook file into various static formats including:
(define-public python2-nbconvert
(package-with-python2 python-nbconvert))
-(define-public python-prometheus-client
- (package
- (name "python-prometheus-client")
- (version "0.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "prometheus_client" version))
- (sha256
- (base32
- "0g7rpv1pq2lab1nfqdx98z9d3bqwc400alg1j4ynrpjkrbsizhg8"))))
- (build-system python-build-system)
- (arguments '(#:tests? #f)) ; tests are not included
- (propagated-inputs
- `(("python-twisted" ,python-twisted)))
- (home-page "https://github.com/prometheus/client_python")
- (synopsis "Python client for the Prometheus monitoring system")
- (description
- "This package provides a Python client for the Prometheus monitoring
-system.")
- (license license:asl2.0)))
-
-(define-public python2-prometheus-client
- (package-with-python2 python-prometheus-client))
-
(define-public python-notebook
(package
(name "python-notebook")
@@ -7142,13 +7108,13 @@ config files.")
(define-public python-configargparse
(package
(name "python-configargparse")
- (version "0.12.0")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "ConfigArgParse" version))
(sha256
(base32
- "0fgkiqh6r3rbkdq3k8c48m85g52k96686rw3a6jg4lcncrkpvk98"))))
+ "149fy4zya0rsnlkvxbbq43cyr8lscb5k4pj1m6n7f1grwcmzwbif"))))
(build-system python-build-system)
(native-inputs
`(("python-pyyaml" ,python-pyyaml)))
@@ -7452,27 +7418,6 @@ output, progress bar display, and pipes.")
(define-public python2-clint
(package-with-python2 python-clint))
-(define-public python-astor
- (package
- (name "python-astor")
- (version "0.5")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "astor" version))
- (sha256
- (base32
- "1fdafq5hkis1fxqlmhw0sn44zp2ar46nxhbc22cvwg7hsd8z5gsa"))))
- (build-system python-build-system)
- (home-page "https://github.com/berkerpeksag/astor")
- (synopsis "Read and write Python ASTs")
- (description
- "Astor is designed to allow easy manipulation of Python source via the
-Abstract Syntax Tree.")
- (license license:bsd-3)))
-
-(define-public python2-astor
- (package-with-python2 python-astor))
-
(define-public python-rply
(package
(name "python-rply")
@@ -8806,14 +8751,14 @@ Python. It generates C++ code and a Makefile."))
(define-public python2-rope
(package
(name "python2-rope")
- (version "0.10.3")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rope" version))
(sha256
(base32
- "18k5znhpwvrfck3yp0jmhd5j8r0f0s8bk1zh5yhs2cfgmfhbwigb"))))
+ "1cppm0pa9aqgsbkq130lskrzmrvjs5vpiavjjbhpz2fdw52w8251"))))
(arguments
;; Rope is currently python-2 only.
;; https://github.com/python-rope/rope/issues/57
@@ -9909,28 +9854,6 @@ reasoning, wrappers for natural language processing libraries.")
(define-public python2-pymongo
(package-with-python2 python-pymongo))
-(define-public python-sh
- (package
- (name "python-sh")
- (version "1.11")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "sh" version))
- (sha256
- (base32
- "192r0mpv6dmkysjzhc43ddffiwb5g7c76bgr1mb1z2xz9awbj3sr"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; no tests
- (home-page "https://github.com/amoffat/sh")
- (synopsis "Python subprocess interface")
- (description "Abstracts process invocation by providing a function
-interface for programs.")
- (license license:expat)))
-
-(define-public python2-sh
- (package-with-python2 python-sh))
-
(define-public python-consul
(package
(name "python-consul")
@@ -13240,16 +13163,17 @@ and works only with Python 2 and NumPy < 1.9.")
(define-public python-send2trash
(package
(name "python-send2trash")
- (version "1.4.2")
+ (version "1.5.0")
(source
- (origin (method url-fetch)
+ (origin (method git-fetch)
;; Source tarball on PyPI doesn't include tests.
- (uri (string-append "https://github.com/hsoft/send2trash/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/hsoft/send2trash.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ffyhwjyx61slkdy38iwjc4gmj7fj9gs2q58f075gwvq630pzm9z"))))
+ "1c76zldhw2ay7q7r00nnzcampjz9lkqfcbzqpm0iqp5i6bmmv30v"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -14725,11 +14649,14 @@ of Python libraries for building Python applications.")
;; FIXME: There are two errors and two test failures.
(arguments `(#:tests? #f))
(home-page "https://github.com/berkerpeksag/astor")
- (synopsis "Read/rewrite/write Python ASTs")
+ (synopsis "Read and write Python ASTs")
(description "Astor is designed to allow easy manipulation of Python
-source via the AST.")
+source via the Abstract Syntax Tree.")
(license license:bsd-3)))
+(define-public python2-astor
+ (package-with-python2 python-astor))
+
(define-public python-grpcio
(package
(name "python-grpcio")