summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm184
1 files changed, 128 insertions, 56 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b97e21a62..20b8784c05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2020 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
@@ -75,6 +75,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Matthew Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -981,8 +982,17 @@ to rebuild the original object tree.
Because only safe literals are encoded, it is safe to send serpent data to
other machines, such as over the network.")
+ (properties `((python2-variant . ,(delay python2-serpent))))
(license license:expat)))
+(define-public python2-serpent
+ (let ((base (package-with-python2 (strip-python2-variant python-serpent))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python-enum34" ,python2-enum34)
+ ,@(package-propagated-inputs base))))))
+
(define-public python-setuptools
(package
(name "python-setuptools")
@@ -2259,14 +2269,14 @@ from git information.
(define-public python-pyrsistent
(package
(name "python-pyrsistent")
- (version "0.15.7")
+ (version "0.16.0")
(home-page "https://github.com/tobgu/pyrsistent")
(source (origin
(method url-fetch)
(uri (pypi-uri "pyrsistent" version))
(sha256
(base32
- "103j63g6lb5dfspph96zxjdpnq9h991kazd4f09ddgkpxpivbiyd"))))
+ "1lrsjgblnapfimd0alsi1as5nz2lfqv97131l7d6anbjzq2rjri8"))))
(build-system python-build-system)
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
@@ -2813,8 +2823,7 @@ environments and back.")
"PyYAML is a YAML parser and emitter for Python. PyYAML features a
complete YAML 1.1 parser, Unicode support, pickle support, capable extension
API, and sensible error messages. PyYAML supports standard YAML tags and
-provides Python-specific tags that allow to represent an arbitrary Python
-object.")
+provides Python-specific tags that represent an arbitrary Python object.")
(license license:expat)))
(define-public python2-pyyaml
@@ -3543,7 +3552,7 @@ receive files via the SCP1 protocol, as implemented by the OpenSSH
;; Note: As of version 1.7 the documentation is not worth building.
(home-page "https://github.com/jaraco/rst.linker")
(synopsis "Sphinx plugin to add links and timestamps")
- (description "rst.linker allows to automatically replace text by a
+ (description "rst.linker automatically replaces text by a
reStructuredText external reference or timestamps. It's primary purpose is to
augment the changelog, but it can be used for other documents, too.")
(license license:expat)))
@@ -6773,14 +6782,14 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python-datrie
(package
(name "python-datrie")
- (version "0.8")
+ (version "0.8.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "datrie" version))
(sha256
(base32
- "0338r8xgmpy78556jhms0h6qkvyjr10p8bpgdvcpqzm9lrmxmmdx"))))
+ "0pbn32flkrpjiwfcknmj6398qa81ba783kbcvwan3kym73v0hnsj"))))
(build-system python-build-system)
(native-inputs
`(("python-cython" ,python-cython)
@@ -11665,14 +11674,14 @@ until the object is actually required, and caches the result of said call.")
(define-public python-dnspython
(package
(name "python-dnspython")
- (version "1.15.0")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append "http://www.dnspython.org/kits/"
version "/dnspython-" version ".tar.gz"))
(sha256
(base32
- "0jr4v2pd90i6l1xxbss2m05psbjaxvyvvvpq44wycijpfgjqln8i"))))
+ "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
(build-system python-build-system)
(arguments '(#:tests? #f)) ; XXX: requires internet access
(home-page "http://www.dnspython.org")
@@ -11903,15 +11912,14 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.16.0")
+ (version "0.17.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
- (patches (search-patches "python-jedi-deleted-variables.patch"))
(sha256
(base32
- "1mb5kmrk9bkc3kwzx02j62cdan1jqd92q1z7h7wi9d30jg5p3j6m"))))
+ "0c1h9x3a9klvk2g288wl328x8xgzw7136k6vs9hkd56b85vcjh6z"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -12649,7 +12657,7 @@ by system tools such as ps and top).
Changing the title is mostly useful in multi-process systems, for
example when a master process is forked: changing the children's title
-allows to identify the task each process is busy with. The technique
+allows identifying the task each process is busy with. The technique
is used by PostgreSQL and the OpenSSH Server for example.")
(license license:bsd-3)
(properties `((python2-variant . ,(delay python2-setproctitle))))))
@@ -16241,14 +16249,14 @@ time-based (TOTP) passwords.")
(define-public python-parso
(package
(name "python-parso")
- (version "0.6.2")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "parso" version))
(sha256
(base32
- "0mr1j4ijqnrihz1yap34g6i8vjldg5lz814sz4v0d8pbqvh5jmhc"))))
+ "0b7irps2dqmzq41sxbpvxbivhh1x2hwmbqp45bbpd82446p9z3lh"))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(build-system python-build-system)
@@ -17113,26 +17121,35 @@ pure-Python.")
(define-public python-cloudpickle
(package
(name "python-cloudpickle")
- (version "0.6.1")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cloudpickle" version))
(sha256
(base32
- "1wdw89mlm7fqa3fm3ymskx05jrys66n8m1z1a8s0mss0799ahsgi"))))
+ "0lx7gy9clp427qwcm7b23zdsldpr03gy3vxxhyi8fpbhwz859brq"))))
(build-system python-build-system)
- ;; FIXME: there are 5 errors in 122 tests:
- ;; ERROR: test_function_pickle_compat_0_4_0 (tests.cloudpickle_test.CloudPickleTest)
- ;; ERROR: test_function_pickle_compat_0_4_1 (tests.cloudpickle_test.CloudPickleTest)
- ;; ERROR: test_function_pickle_compat_0_4_0 (tests.cloudpickle_test.Protocol2CloudPickleTest)
- ;; ERROR: test_function_pickle_compat_0_4_1 (tests.cloudpickle_test.Protocol2CloudPickleTest)
- ;; ERROR: test_temp_file (tests.cloudpickle_file_test.CloudPickleFileTests)
- ;; TypeError: cannot serialize '_io.BufferedRandom' object
- (arguments '(#:tests? #f))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'do-not-override-PYTHONPATH
+ (lambda _
+ ;; Append to PYTHONPATH instead of overriding it so
+ ;; that dependencies from Guix can be found.
+ (substitute* "tests/testutils.py"
+ (("env\\['PYTHONPATH'\\] = pythonpath")
+ "env['PYTHONPATH'] += os.pathsep + pythonpath"))
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-s" "-vv")
+ (format #t "test suite not run~%"))
+ #t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-mock" ,python-mock)
+ `(;; For tests.
+ ("python-psutil" ,python-psutil)
+ ("python-pytest" ,python-pytest)
("python-tornado" ,python-tornado)))
(home-page "https://github.com/cloudpipe/cloudpickle")
(synopsis "Extended pickling support for Python objects")
@@ -17142,10 +17159,19 @@ supported by the default pickle module from the Python standard library. It
is especially useful for cluster computing where Python expressions are
shipped over the network to execute on remote hosts, possibly close to the
data.")
+ (properties `((python2-variant . ,(delay python2-cloudpickle))))
(license license:bsd-3)))
(define-public python2-cloudpickle
- (package-with-python2 python-cloudpickle))
+ (let ((base (package-with-python2 (strip-python2-variant python-cloudpickle))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python-mock" ,python2-mock)
+ ,@(package-native-inputs base)))
+ (propagated-inputs
+ `(("python-futures" ,python2-futures)
+ ,@(package-propagated-inputs base))))))
(define-public python-locket
(package
@@ -17256,13 +17282,13 @@ decisions with any given backend.")
(define-public python-dask
(package
(name "python-dask")
- (version "2.9.0")
+ (version "2.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dask" version))
(sha256
- (base32 "1w1hqr8vyx6ygwflj2737dcy0mmgvrc0s602gnny8pzlcbs9m76b"))))
+ (base32 "031j0j26s0675v0isyps2dphm03330n7dy8ifdy70jgvf78d119q"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -18557,14 +18583,14 @@ tests.")
(define-public python-gssapi
(package
(name "python-gssapi")
- (version "1.6.1")
+ (version "1.6.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "gssapi" version))
(sha256
(base32
- "1gymg4asvwrz7y13qpwp2s5g8qwq179d72gkj09q6bfcgs82l5wr"))))
+ "02i5s7998dg5kcr4m0xwamd8vjqk1816xbzldyp68l91f6bynwcr"))))
(build-system python-build-system)
(propagated-inputs
`(("python-decorator" ,python-decorator)
@@ -18727,6 +18753,29 @@ dedicated platform. The tool proposes a unified interface for any format and
an upload option to send your work back to the platform.")
(license license:gpl3+)))
+(define-public python-titlecase
+ (package
+ (name "python-titlecase")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "titlecase" version))
+ (sha256
+ (base32
+ "0486i99wf8ssa7sgn81fn6fv6i4rhhq6n751bc740b3hzfbpmpl4"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/ppannuto/python-titlecase")
+ (synopsis "Capitalize strings similar to book titles")
+ (description
+ "Python-Titlecase is a Python port of John Gruber's titlecase.pl.
+It capitalizes (predominantly English) strings in a way that is similar to
+book titles, using the New York Times Manual of Style to leave certain words
+lowercase.")
+ (license license:expat)))
+
(define-public python-pypng
(package
(name "python-pypng")
@@ -18978,7 +19027,7 @@ logging in Python. It also provides some custom formatters and handlers.")
(home-page "https://github.com/jd/pifpaf")
(synopsis "Tools and fixtures to manage daemons for testing in Python")
(description "Pifpaf is a suite of fixtures and a command-line tool that
-allows to start and stop daemons for a quick throw-away usage. This is typically
+starts and stops daemons for a quick throw-away usage. This is typically
useful when needing these daemons to run integration testing. It originally
evolved from its precursor @code{overtest}.")
(license license:asl2.0)))
@@ -19186,28 +19235,6 @@ simple and fast to verify, and decouple authorization policy from the
enforcement of that policy.")
(license license:expat)))
-(define-public python-prometheus-client
- (package
- (name "python-prometheus-client")
- (version "0.7.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "prometheus_client" version))
- (sha256
- (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
- (build-system python-build-system)
- (arguments
- ;; TODO: No tests in the PyPI distribution.
- `(#:tests? #f))
- (propagated-inputs
- `(("python-twisted" ,python-twisted)))
- (home-page "https://github.com/prometheus/client_python")
- (synopsis "Prometheus instrumentation library")
- (description
- "This is the official Python client for the Prometheus monitoring server.")
- (license license:asl2.0)))
-
(define-public python-ldap3
(package
(name "python-ldap3")
@@ -19450,3 +19477,48 @@ an identity provider. The distribution contains examples of both.
This package was originally written to work in a WSGI environment, but
there are extensions that allow you to use it with other frameworks.")
(license license:asl2.0)))
+
+(define-public python-click-plugins
+ (package
+ (name "python-click-plugins")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "click-plugins" version))
+ (sha256
+ (base32 "0jr6bxj67vg988vkm6nz8jj98v9lg46bn49lkhak3n598jbrkas6"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (synopsis "Extension for Click to register external CLI commands")
+ (description "This package provides n extension module for Click to
+register external CLI commands via setuptools entry-points.")
+ (home-page "https://github.com/click-contrib/click-plugins")
+ (license license:bsd-3)))
+
+(define-public python-diceware
+ (package
+ (name "python-diceware")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diceware" version))
+ (sha256
+ (base32
+ "0klb0ysybzlh2wihvir82hgq62v0jjmlcqklwajyms7c0p529yby"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/ulif/diceware/")
+ (synopsis "Generates memorable passphrases")
+ (description "This package generates passphrases by concatenating words
+randomly picked from wordlists. It supports several sources of
+randomness (including real life dice) and different wordlists (including
+cryptographically signed ones).")
+ (license license:gpl3+)))