summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e01e115e92..901b241a24 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19017,3 +19017,29 @@ actions: actions can spawn other actions, and eventually they either succeed
or fail. The resulting logs tell you the story of what your software did: what
happened, and what caused it.")
(license license:asl2.0)))
+
+(define-public python-pem
+ (package
+ (name "python-pem")
+ (version "20.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pem" version))
+ (sha256
+ (base32
+ "1xh88ss279fprxnzd10dczmqwjhppbyvljm33zrg2mgybwd66qr7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-certifi" ,python-certifi)
+ ("python-coverage" ,python-coverage)
+ ("python-pretend" ,python-pretend)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytest" ,python-pytest)
+ ("python-sphinx" ,python-sphinx)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://pem.readthedocs.io/")
+ (synopsis "Easy PEM file parsing in Python")
+ (description
+ "This package provides a Python module for parsing and splitting PEM files.")
+ (license license:expat)))