summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78453b2974..1968c987df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2937,14 +2937,14 @@ and is very extensible.")
(define-public python-cython
(package
(name "python-cython")
- (version "0.29.5")
+ (version "0.29.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cython" version))
(sha256
(base32
- "1wfb68g115gmf3mv23w0hh972b0ll85gpb92ci28x6h997br0llx"))))
+ "1bp7cn0pp5qy63k9hbp4ka34fm01kvysh478phpkhr68npqk6pbc"))))
(build-system python-build-system)
;; we need the full python package and not just the python-wrapper
;; because we need libpython3.3m.so
@@ -2976,9 +2976,6 @@ and is very extensible.")
(replace 'check
(lambda _
- ;; The "with_outer_raising" test fails with Python 3.7. See
- ;; https://github.com/cython/cython/issues/2454
- (delete-file "tests/run/generators_py.py")
(invoke "python" "runtests.py" "-vv"))))))
(home-page "http://cython.org/")
(synopsis "C extensions for Python")
@@ -3390,13 +3387,13 @@ library, libgit2 implements Git plumbing.")
(define-public python-pyparsing
(package
(name "python-pyparsing")
- (version "2.2.1")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyparsing" version))
(sha256
- (base32 "06dgd0iilvf8m0ssmfpcbh8l6jf0zkp8adbb84llksg17crfx4zl"))))
+ (base32 "0yk6xl885b91dmlhlsap7x78hk2rdr879fln9anbq6k4ca42djb6"))))
(build-system python-build-system)
(outputs '("out" "doc"))
(arguments