summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17b6aa41c7..b010f42647 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5757,9 +5757,9 @@ computing.")
(add-before 'check 'delete-broken-tests
(lambda* (#:key inputs #:allow-other-keys)
;; These tests throw errors for unknown reasons.
+ (delete-file "IPython/core/tests/test_displayhook.py")
+ (delete-file "IPython/core/tests/test_magic_terminal.py")
(delete-file "IPython/core/tests/test_profile.py")
- (delete-file "IPython/core/tests/test_interactiveshell.py")
- (delete-file "IPython/core/tests/test_magic.py")
#t)))))
(home-page "https://ipython.org")
(synopsis "IPython is a tool for interactive computing in Python")
@@ -8186,6 +8186,7 @@ in the data.")
(description "This package provides a terminal-based console frontend for
Jupyter kernels. It also allows for console-based interaction with non-Python
Jupyter kernels such as IJulia and IRKernel.")
+ (properties `((python2-variant . ,(delay python2-jupyter-console))))
(license license:bsd-3)))
(define-public python2-jupyter-console
@@ -8200,8 +8201,9 @@ Jupyter kernels such as IJulia and IRKernel.")
(base32
"1kam1qzgwr7srhm5r6aj90di5sws4bq0jmiw15452ddamb9yspal"))))
(build-system python-build-system)
- ;; Tests only run in an TTY.
- (arguments `(#:tests? #f))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; Tests only run in a TTY.
(propagated-inputs
`(("python2-ipykernel" ,python2-ipykernel)
("python2-jupyter-client" ,python2-jupyter-client)