summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6b0645376..37fc53536a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6346,7 +6346,12 @@ so it might be a tiny bit slower.")
(modify-phases %standard-phases
(replace 'build
(lambda _
- (invoke "python" "waf-light" "configure" "build")))
+ ;; XXX: Find a way to add all extra tools.
+ (let ((tools '("gccdeps"
+ "clang_compilation_database")))
+ (invoke "python" "waf-light" "configure" "build"
+ (string-append "--tools="
+ (string-join tools ","))))))
(replace 'check
(lambda _
(invoke "python" "waf" "--version")))