summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm246
1 files changed, 117 insertions, 129 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 181899da36..e3e2b5f0d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -314,14 +314,14 @@ by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
(define-public python-babel
(package
(name "python-babel")
- (version "2.6.0")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Babel" version))
(sha256
(base32
- "08rxmbx2s4irp0w0gmn498vns5xy0fagm0fg33xa772jiks51flc"))))
+ "0a7wawx8vsg7igvz6p3x909fskhg4b2y1910xk4f4c8y22p3aqg8"))))
(build-system python-build-system)
(native-inputs
`(("python-freezegun" ,python-freezegun)
@@ -331,7 +331,14 @@ by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "pytest" "-vv"))))))
+ (lambda _
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; XXX: These tests fail when using Pytest 4.x and
+ ;; Babel 2.6.0. Try removing this for later versions.
+ "not test_no_inherit_metazone_marker_never_in_output"
+ " and not test_smoke_dates"
+ " and not test_smoke_numbers")))))))
(home-page "http://babel.pocoo.org/")
(synopsis
"Tools for internationalizing Python applications")
@@ -346,6 +353,18 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+;; Sphinx < 2.0 requires this version. Remove once no longer needed.
+(define-public python2-babel-2.6
+ (package
+ (inherit python2-babel)
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Babel" version))
+ (sha256
+ (base32
+ "08rxmbx2s4irp0w0gmn498vns5xy0fagm0fg33xa772jiks51flc"))))))
+
(define-public python2-backport-ssl-match-hostname
(package
(name "python2-backport-ssl-match-hostname")
@@ -648,14 +667,14 @@ other machines, such as over the network.")
(define-public python-setuptools
(package
(name "python-setuptools")
- (version "40.0.0")
+ (version "40.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "setuptools" version ".zip"))
(sha256
(base32
- "0pq116lr14gnc62v76nk0npkm6krb2mpp7p9ab369zgv4n7dnah1"))
+ "0k9hifpgahnw2a26w3cr346iy733k6d3nwh3f7g9m13y6f8fqkkf"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -972,14 +991,14 @@ from the Python interpreter, or as a small part of a larger application.")
(define-public python-six
(package
(name "python-six")
- (version "1.11.0")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "six" version))
(sha256
(base32
- "1scqzwc51c875z23phj48gircqjgnn3af8zy2izjwmnlxrxsgs3h"))))
+ "0wxs1q74v07ssjywbbm7x6h5v9qx209ld2yfsif4060sxi0h2sni"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1641,14 +1660,14 @@ server.")
(define-public python-py
(package
(name "python-py")
- (version "1.5.4")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "py" version))
(sha256
(base32
- "1xxvwfn82457djf55f5n2c94699rfqnk43br8fif2r2q8gvrmm9z"))))
+ "0lsy1gajva083pzc7csj1cvbmminb7b4l6a0prdzyb3fd829nqyw"))))
(build-system python-build-system)
(arguments
;; FIXME: "ImportError: 'test' module incorrectly imported from
@@ -2185,13 +2204,13 @@ JavaScript-like message boxes. Types of dialog boxes include:
(package
(name "python-pympler")
(home-page "https://pythonhosted.org/Pympler/")
- (version "0.5")
+ (version "0.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "Pympler" version))
(sha256
(base32
- "03qwsbilqgvnbl3a1jmpgixbr2kq6m3fvdlzyr3wdp01bwlc85kx"))))
+ "19qkpaw5icwhb4c0f6ijqfmhwhj34k2k6s4m4fsvhrxc9p5cwqn2"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -2327,15 +2346,33 @@ e.g. filters, callbacks and errbacks can all be promises.")
(define-public python-markupsafe
(package
(name "python-markupsafe")
- (version "1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "MarkupSafe" version))
(sha256
(base32
- "0rdn1s8x9ni7ss8rfiacj7x1085lx8mh2zdwqslnw8xc3l4nkgm6"))))
+ "0sqipg4fk7xbixqd8kq6rlkxj664d157bdwbh93farcphf92x1r9"))))
(build-system python-build-system)
+ (arguments
+ `(#:modules ((ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((cwd (getcwd))
+ (libdir (find (cut string-prefix? "lib." <>)
+ (scandir "build"))))
+ (setenv "PYTHONPATH"
+ (string-append cwd "/build/" libdir ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/mitsuhiko/markupsafe")
(synopsis "XML/HTML/XHTML markup safe string implementation for Python")
(description
@@ -2513,14 +2550,14 @@ reStructuredText.")
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.4.0")
+ (version "2.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1xb5n3hvhk63kxypc03k7kfry20pny6gygi4bsl9kw1rnzzsdjri"))))
+ "15v2sqm5g12bqa0c7wikfh9ck2nl97ayizy1hpqhmws5gqalq748"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests require sphinx, which depends on this.
@@ -4140,14 +4177,14 @@ as the original project seems to have been abandoned circa 2007.")
(define-public python-pycodestyle
(package
(name "python-pycodestyle")
- (version "2.4.0")
+ (version "2.5.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pycodestyle" version))
- (sha256
- (base32
- "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycodestyle" version))
+ (sha256
+ (base32
+ "0v4prb05n21bm8650v0a01k1nyqjdmkrsm3zycfxh2j5k9n962p4"))))
(build-system python-build-system)
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")
@@ -4809,13 +4846,13 @@ child application and control it as if a human were typing commands.")
(define-public python-setuptools-scm
(package
(name "python-setuptools-scm")
- (version "3.1.0")
+ (version "3.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "setuptools_scm" version))
(sha256
(base32
- "0h4bglwfz8b9prqljv8z3w9rgydfyxzaj05bm1y6zs5m6shz548i"))))
+ "0n3knn3p1sqlx31k2lahn7z9bacvlv8nhlfidj77vz50bxqlgasj"))))
(build-system python-build-system)
(home-page "https://github.com/pypa/setuptools_scm/")
(synopsis "Manage Python package versions in SCM metadata")
@@ -6266,14 +6303,14 @@ PEP 8.")
(define-public python-pyflakes
(package
(name "python-pyflakes")
- (version "2.0.0")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
- "0jba28czyvimdc72llms3f17swp3i8jdcabf5w0j00adfbn64xls"))))
+ "18pq95a1xj2dgdd0m85gyfsn40jajj4xc3lp8wfv7igqhrc86xnr"))))
(build-system python-build-system)
(home-page
"https://github.com/pyflakes/pyflakes")
@@ -6362,35 +6399,20 @@ complexity of Python source code.")
(define-public python2-pyflakes-0.8.1
(package-with-python2 python-pyflakes-0.8.1))
-;; This package is used by hypothesis which has thousands of dependent packages.
-;; FIXME: Consolidate this with "python-flake8" below in the next rebuild cycle.
-(define-public python-flake8-3.5
+(define-public python-flake8
(package
(name "python-flake8")
- (version "3.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "184b33grvvjmiwlv9kyd7yng9qv5ld24154j70z332xxg9gjclvj"))))
+ (version "3.7.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "0qg6zggqigrd4k3gv88shd1a27d0cwgfql8vfiq2c7rl7w3rd6c5"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Two errors don't seem to have assigned codes.
- (add-after 'unpack 'delete-broken-test
- (lambda _ (delete-file "tests/unit/test_pyflakes_codes.py") #t))
- (add-after 'unpack 'fix-problem-with-pycodestyle
- (lambda _
- ;; See https://gitlab.com/pycqa/flake8/merge_requests/230
- ;; This should no longer be needed with the next release.
- (substitute* "setup.py"
- (("PEP8_PLUGIN\\('break_around_binary_operator'\\),")
- "PEP8_PLUGIN('break_after_binary_operator'),\
-PEP8_PLUGIN('break_before_binary_operator'),"))
- #t))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -6399,6 +6421,7 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
#t)))))
(propagated-inputs
`(("python-pycodestyle" ,python-pycodestyle)
+ ("python-entrypoints" ,python-entrypoints)
("python-pyflakes" ,python-pyflakes)
("python-mccabe" ,python-mccabe)))
(native-inputs
@@ -6410,45 +6433,18 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
- (properties `((python2-variant . ,(delay python2-flake8-3.5))))
+ (properties `((python2-variant . ,(delay python2-flake8))))
(license license:expat)))
-(define-public python2-flake8-3.5
- (let ((base (package-with-python2 (strip-python2-variant python-flake8-3.5))))
+(define-public python2-flake8
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
("python2-enum34" ,python2-enum34)
+ ("python2-typing" ,python2-typing)
,@(package-propagated-inputs base))))))
-;; Version 3.5.0 has compatibility issues with Pyflakes 2.0, so we need
-;; this newer version. Keep it as a separate variable for now to avoid
-;; rebuilding "python-hypothesis"; this should be removed in the next
-;; rebuild cycle.
-(define-public python-flake8
- (package
- (inherit python-flake8-3.5)
- (version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-flake8-3.5)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'delete-broken-test)
- (delete 'fix-problem-with-pycodestyle)))))
- (properties `((python2-variant . ,(delay python2-flake8))))))
-
-(define-public python2-flake8
- (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
- (package (inherit base)
- (propagated-inputs
- (package-propagated-inputs python2-flake8-3.5)))))
-
;; python-hacking requires flake8 <2.6.0.
(define-public python-flake8-2.5
(package
@@ -6676,13 +6672,13 @@ add functionality and customization to your projects with their own plugins.")
(define-public python-fonttools
(package
(name "python-fonttools")
- (version "3.28.0")
+ (version "3.38.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "fonttools" version ".zip"))
(sha256
(base32
- "0vsvjhidpb5kywpjgz1j3fywzkddxkb0afqai18qa3h6lqjyxwpb"))))
+ "12ripk3s7skgxr1bs9r8n13r94ym3s8iir7ivfixls9fa4dabmlh"))))
(build-system python-build-system)
(native-inputs
`(("unzip" ,unzip)
@@ -7820,6 +7816,8 @@ simulation, statistical modeling, machine learning and much more.")
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(build-system python-build-system)
+ ;; XXX: Incompatible with Pytest 4: <https://github.com/chardet/chardet/issues/173>.
+ (arguments `(#:tests? #f))
(home-page "https://github.com/chardet/chardet")
(synopsis "Universal encoding detector for Python 2 and 3")
(description
@@ -8066,13 +8064,13 @@ tables.")
(define-public python-atomicwrites
(package
(name "python-atomicwrites")
- (version "1.1.5")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "atomicwrites" version))
(sha256
(base32
- "11bm90fwm2avvf4f3ib8g925w7jr4m11vcsinn1bi6ns4bm32214"))))
+ "19ngcscdf3jsqmpcxn6zl5b6anmsajb6izp1smcd1n02midl9abm"))))
(build-system python-build-system)
(synopsis "Atomic file writes in Python")
(description "Library for atomic file writes using platform dependent tools
@@ -8385,11 +8383,14 @@ otherwise matches 3.2’s API.")
(base32
"0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2
- ;; FIXME: Python 2.7.14 moved the test.support library,
- ;; but our package has not yet been adjusted. Enable
- ;; tests when the python2 package has been fixed.
- #:tests? #f))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test_futures.py")
+ #t)))))
(home-page "https://github.com/agronholm/pythonfutures")
(synopsis
"Backport of the concurrent.futures package from Python 3.2")
@@ -8481,14 +8482,14 @@ library as well as on the command line.")
(define-public python-pluggy
(package
(name "python-pluggy")
- (version "0.7.1")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pluggy" version))
(sha256
(base32
- "1qbn70mksmr03hac6jgp6fiqc4l7859z8dchx2x950vhlij87swm"))))
+ "13yg2q0wgcb4l8lgdvcnzqa8db5lrw3nwn50lxjy1z5jkp7gkv0r"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -8641,14 +8642,14 @@ python-xdo for newer bindings.)")
(define-public python-mako
(package
(name "python-mako")
- (version "1.0.10")
+ (version "1.0.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Mako" version))
(sha256
(base32
- "0r9rysn19fmrxnzfcn7sg20kjhcrx9qri0my9n5vdzp1g2g92rbi"))))
+ "0qj16ai937wrbpv1a9g395gybb9s06rmdj3arbp8fpl37bg6byhc"))))
(build-system python-build-system)
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
@@ -9122,13 +9123,13 @@ anymore.")
(define-public python2-pathlib2
(package
(name "python2-pathlib2")
- (version "2.3.2")
+ (version "2.3.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "pathlib2" version))
(sha256
(base32
- "10yb0iv5x2hs631rcppkhbddx799d3h8pcwmkbh2a66ns3w71ccf"))))
+ "0hpp92vqqgcd8h92msm9slv161b1q160igjwnkf2ag6cx0c96695"))))
(build-system python-build-system)
;; We only need the the Python 2 variant, since for Python 3 our minimum
;; version is 3.4 which already includes this package as part of the
@@ -11823,15 +11824,6 @@ protocols.")
(package
(inherit python-attrs)
(name "python-attrs-bootstrap")
- ;; Keep this on a fixed version so python-attrs can be updated without
- ;; triggering a mass-rebuild. FIXME: Update this in the next rebuild cycle.
- (version "17.4.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "attrs" version))
- (sha256
- (base32
- "1jafnn1kzd6qhxgprhx6y6ik1r5m2rilx25syzcmq03azp660y8w"))))
(native-inputs `())
(arguments `(#:tests? #f))))
@@ -12131,17 +12123,14 @@ of @code{functools.lru_cache} from python 3.3.")
(define-public python-configparser
(package
(name "python-configparser")
- (version "3.5.0")
+ (version "3.7.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://bitbucket.org/ambv/configparser/get/"
- version ".tar.bz2"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "configparser" version))
(sha256
(base32
- "0waq40as14abwzbb321hfz4vr1fi363nscy32ga14qvfygrg96wa"))))
+ "0cnz213il9lhgda6x70fw7mfqr8da43s3wm343lwzhqx94mgmmav"))))
(build-system python-build-system)
(home-page "https://github.com/jaraco/configparser/")
(synopsis "Backport of configparser from python 3.5")
@@ -14457,41 +14446,40 @@ file system events on Linux.")
(define-public python-more-itertools
(package
(name "python-more-itertools")
- (version "4.3.0")
+ (version "7.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "more-itertools" version))
(sha256
(base32
- "17h3na0rdh8xq30w4b9pizgkdxmm51896bxw600x84jflg9vaxn4"))))
+ "0npsg9rbzvjrf176bf1p7239lkq0laqv11j81aixpn5al65p9r63"))))
(build-system python-build-system)
- (arguments
- `(,@(if (any (cute string-prefix? <> (or (%current-system)
- (%current-target-system)))
- '("armhf" "i686"))
- '(#:phases
- (modify-phases %standard-phases
- ;; This is required for 32-bit hardware.
- ;; TODO: Try to remove this when upgrading.
- (add-after 'unpack 'patch-test
- (lambda _
- (substitute* "more_itertools/tests/test_more.py"
- (("10 \\*\\* 10") "9 ** 9"))
- #t))))
- '())))
- (propagated-inputs
- `(("python-six" ,python-six-bootstrap)))
(home-page "https://github.com/erikrose/more-itertools")
(synopsis "More routines for operating on iterables, beyond itertools")
(description "Python's built-in @code{itertools} module implements a
number of iterator building blocks inspired by constructs from APL, Haskell,
and SML. @code{more-itertools} includes additional building blocks for
working with iterables.")
+ (properties `((python2-variant . ,(delay python2-more-itertools))))
(license license:expat)))
+;; The 5.x series are the last versions supporting Python 2.7.
(define-public python2-more-itertools
- (package-with-python2 python-more-itertools))
+ (package
+ (inherit python-more-itertools)
+ (name "python2-more-itertools")
+ (version "5.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "more-itertools" version))
+ (sha256
+ (base32
+ "1r12cm6mcdwdzz7d47a6g4l437xsvapdlgyhqay3i2nrlv03da9q"))))
+ (arguments
+ `(#:python ,python2-minimal))
+ (propagated-inputs
+ `(("python2-six" ,python2-six-bootstrap)))))
(define-public python-latexcodec
(package