summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 58d09ced57..eb40abe619 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13459,10 +13459,17 @@ Supported metrics are:
@item Halstead metrics (all of them)
@item the Maintainability Index (a Visual Studio metric)
@end itemize")
+ (properties `((python2-variant . ,(delay python2-radon))))
(license license:expat)))
(define-public python2-radon
- (package-with-python2 python-radon))
+ (let ((base (package-with-python2 (strip-python2-variant python-radon))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python-configparser" ,python2-configparser)
+ ("python-future" ,python2-future)
+ ,@(package-propagated-inputs base))))))
(define-public python-sure
(package