summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm52
1 files changed, 36 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 67f4e47e8e..8f4a2334d9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3996,14 +3996,14 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(define-public python-matplotlib
(package
(name "python-matplotlib")
- (version "3.1.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "matplotlib" version))
(sha256
(base32
- "14qc109dibp32xfd9lah54djc0rc76fhbsj9cwyb328lzqmd5sqz"))))
+ "1nmshfqh7wyg15i16hx1yiylcvzkws29ivn66n3i0wyqwcpjr3lf"))))
(build-system python-build-system)
(propagated-inputs ; the following packages are all needed at run time
`(("python-cycler" ,python-cycler)
@@ -4068,8 +4068,14 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(for-each delete-file
;; test_normal_axes, test_get_tightbbox_polar
'("lib/matplotlib/tests/test_axes.py"
+ ;; We don't use the webagg backend and this test forces it.
+ "lib/matplotlib/tests/test_backend_webagg.py"
;; test_outward_ticks
"lib/matplotlib/tests/test_tightlayout.py"
+ ;; test_hidden_axes fails with minor extent
+ ;; differences, possibly due to the use of a
+ ;; different version of FreeType.
+ "lib/matplotlib/tests/test_constrainedlayout.py"
;; Fontconfig returns no fonts.
"lib/matplotlib/tests/test_font_manager.py"))
#t))
@@ -4087,7 +4093,7 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(lambda* (#:key outputs inputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests.py" "-v"
- "-m" "not network")))
+ "-m" "not network and not webagg")))
(add-before 'build 'configure-environment
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((cairo (assoc-ref inputs "cairo")))
@@ -5944,14 +5950,14 @@ parsing (browser/HTTP) user agent strings.")
(define-public python-dbus
(package
(name "python-dbus")
- (version "1.2.10")
+ (version "1.2.14")
(source
(origin
(method url-fetch)
(uri (string-append "https://dbus.freedesktop.org/releases/dbus-python/"
"dbus-python-" version ".tar.gz"))
(sha256
- (base32 "11nqk01iq5bx2llgb3ksknyinijdp29w4ndj210glm009ayjncyl"))))
+ (base32 "0cdchkgnivlka4lf8q4qfk0yxq483i3r3aqickjf8hfn7nx0c0mi"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -5970,10 +5976,7 @@ implementation of D-Bus.")
(inputs `(("python" ,python-2)
,@(alist-delete "python"
(package-inputs python-dbus)
- equal?)))
- ;; FIXME: on Python 2, the test_utf8 fails with:
- ;; "ValueError: unichr() arg not in range(0x10000) (narrow Python build)"
- (arguments `(#:tests? #f))))
+ equal?)))))
(define-public python-notify2
(package
@@ -6265,7 +6268,19 @@ SVG, EPS, PNG and terminal output.")
(method url-fetch)
(uri (pypi-uri "seaborn" version))
(sha256
- (base32 "0bqysi3fxfjl1866m5jq8z7mynhqbqnikim74dmzn8539iwkzj3n"))))
+ (base32 "0bqysi3fxfjl1866m5jq8z7mynhqbqnikim74dmzn8539iwkzj3n"))
+ (patches
+ (list (origin
+ (method url-fetch)
+ ;; This has already been merged, but there is no new
+ ;; release including this patch. It fixes problems
+ ;; with axis rotation that would lead to test
+ ;; failures.
+ (uri "https://patch-diff.githubusercontent.com/raw/mwaskom/seaborn/pull/1716.diff")
+ (sha256
+ (base32
+ "1lm870z316n9ivsyr86hpk1gxaraw0mrjvq42lqsm0znhjdp9q9w"))
+ (file-name "seaborn-0.9.0-axis-rotation.patch"))))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -6278,6 +6293,12 @@ SVG, EPS, PNG and terminal output.")
(system (format #f "~a/bin/Xvfb :1 &" xorg-server))
(setenv "DISPLAY" ":1")
#t)))
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; test_cbar_ticks fails probably because of matplotlib's
+ ;; expectation of using an older version of FreeType.
+ (delete-file "seaborn/tests/test_matrix.py")
+ #t))
(replace 'check (lambda _ (invoke "pytest" "seaborn") #t)))))
(propagated-inputs
`(("python-pandas" ,python-pandas)
@@ -6286,7 +6307,7 @@ SVG, EPS, PNG and terminal output.")
("python-scipy" ,python-scipy)))
(native-inputs
`(("python-pytest" ,python-pytest)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(home-page "http://stanford.edu/~mwaskom/software/seaborn/")
(synopsis "Statistical data visualization")
(description
@@ -10855,13 +10876,13 @@ it will manage (install/update) them for you.")
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")
- (version "1.4.2")
+ (version "1.4.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "lazy-object-proxy" version))
(sha256
(base32
- "1wgl0fmddi0ind78a74yyk2qrr9pb5llvj1892cdpp6z6n6mn4zx"))))
+ "1w1aaay424ciz8fz3fkzxb0pxzfxn184f2whpyn4fx72bn50x47k"))))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm-3.3)))
(build-system python-build-system)
@@ -14820,15 +14841,14 @@ files, and Makefiles.")
(define-public python-whatever
(package
(name "python-whatever")
- (version "0.5")
+ (version "0.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/Suor/whatever/archive/" version
".tar.gz"))
(sha256
- (base32
- "1iqvnaf0zpc6b4rvbqq4xy45mszcscyzpzknv8wg6j84pbp22sap"))
+ (base32 "1rchg9hrlvw4sn20lq1zspczr4x1pv57c02gv73igiqx1hqpy2nc"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system python-build-system)
(arguments