summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 22 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b188f668a6..5c71298f70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3142,19 +3142,19 @@ and is very extensible.")
(define-public mallard-ducktype
(package
(name "mallard-ducktype")
- (version "1.0.1")
+ (version "1.0.2")
(source
(origin
(method git-fetch)
- ;; git-reference because a proper source tarball is not available
- ;; https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00209.html
+ ;; git-reference because tests are not included in pypi source tarball
+ ;; https://issues.guix.gnu.org/issue/36755#2
(uri (git-reference
(url "https://github.com/projectmallard/mallard-ducktype.git")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0crland0kmpsyjfmnflcw7gaqy5b87b6ah17cmr9d5z1kyazf54n"))))
+ "1jk9bfz7g04ip78s03b0xak6d54rj4h9zpgadkziy1ji216g6y4c"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -10962,25 +10962,36 @@ command @command{natsort} that exposes this functionality in the command line.")
(define-public python-glances
(package
(name "python-glances")
- (version "3.0.2")
+ (version "3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Glances" version))
(sha256
(base32
- "09fxysfp1n16csqvzvawy74qm6a94nvwjf3vcf5gkqp4i6k4vjjy"))))
+ "07j1ggzsqiskyz1i4mrnyr9i95v0dqi0i0hibnv1l188km8shmi8"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Glances phones PyPI for weekly update checks by default.
+ ;; Disable these. The user can re-enable them if desired.
+ (substitute* "glances/outdated.py"
+ (("^(.*)self\\.load_config\\(config\\)\n" line indentation)
+ (string-append indentation
+ "self.args.disable_check_update = True\n"
+ line)))
+ #t))))
(build-system python-build-system)
(propagated-inputs
- `(("python-psutil" ,python-psutil)))
+ `(("python-future" ,python-future)
+ ("python-psutil" ,python-psutil)))
(home-page
"https://github.com/nicolargo/glances")
- (synopsis
- "A cross-platform curses-based monitoring tool")
+ (synopsis "Cross-platform curses-based monitoring tool")
(description
"Glances is a curses-based monitoring tool for a wide variety of platforms.
-Glances uses the PsUtil library to get information from your system. It monitors
-CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
+Glances uses the PsUtil library to get information from your system. It
+monitors CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
(license license:lgpl3+)))
(define-public python2-glances