summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index fee3c39043..bac92eafa9 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -141,6 +141,7 @@ rates.")
(string-append "#" all "\n")))
#t))
(patches (search-patches
+ "pulseaudio-glibc-2.27.patch"
"pulseaudio-fix-mult-test.patch"
"pulseaudio-longer-test-timeout.patch"))))
(build-system gnu-build-system)
@@ -152,6 +153,13 @@ rates.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))
#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; TODO: Remove this custom bootstrap phase when
+ ;; pulseaudio-glibc-2.27.patch is removed.
+ (lambda _
+ (patch-shebang "git-version-gen")
+ (setenv "NOCONFIGURE" "1")
+ (invoke "bash" "bootstrap.sh")))
(add-before 'check 'pre-check
(lambda _
;; 'tests/lock-autospawn-test.c' wants to create a file
@@ -179,7 +187,12 @@ rates.")
("eudev" ,eudev) ;for the detection of hardware audio devices
("check" ,check)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ;; TODO: Remove "autoconf", "automake", and "libtool" from
+ ;; native-inputs when pulseaudio-glibc-2.27.patch is removed.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(propagated-inputs
;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
`(("libcap" ,libcap)