summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 39f54437cb..249afd3f68 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -131,7 +131,7 @@ rates.")
(define-public pulseaudio
(package
(name "pulseaudio")
- (version "11.0")
+ (version "11.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -139,7 +139,7 @@ rates.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0sf92knqkvqmfhrbz4vlsagzqlps72wycpmln5dygicg07a0a8q7"))
+ "17ndr6kc7hpv4ih4gygwlcpviqifbkvnk4fbwf4n25kpb991qlpj"))
(modules '((guix build utils)))
(snippet
;; Disable console-kit support by default since it's deprecated
@@ -158,16 +158,16 @@ rates.")
(string-append "--with-udev-rules-dir="
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))
- #:phases (alist-cons-before
- 'check 'pre-check
- (lambda _
- ;; 'tests/lock-autospawn-test.c' wants to create a file
- ;; under ~/.config/pulse.
- (setenv "HOME" (getcwd))
- ;; 'thread-test' needs more time on hydra and on slower
- ;; machines, so we set the default timeout to 120 seconds.
- (setenv "CK_DEFAULT_TIMEOUT" "120"))
- %standard-phases)))
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; 'tests/lock-autospawn-test.c' wants to create a file
+ ;; under ~/.config/pulse.
+ (setenv "HOME" (getcwd))
+ ;; 'thread-test' needs more time on hydra and on slower
+ ;; machines, so we set the default timeout to 120 seconds.
+ (setenv "CK_DEFAULT_TIMEOUT" "120")
+ #t)))))
(inputs
;; TODO: Add optional inputs (GTK+?).
`(("alsa-lib" ,alsa-lib)