summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm55
1 files changed, 48 insertions, 7 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 12f6f70521..2e681ca97d 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -2,6 +2,8 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,23 +26,24 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3))
+ #:select (bsd-2 bsd-3))
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python))
(define-public protobuf
(package
(name "protobuf")
- (version "2.6.1")
+ (version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/google/protobuf/releases/"
- "download/v" version "/protobuf-"
- version ".tar.bz2"))
+ "download/v" version "/protobuf-cpp-"
+ version ".tar.gz"))
(sha256
(base32
- "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
+ "0y6cr4l7bwa6zvjv5flzr4cx28shk5h8dz99xw90v8qih954pcrb"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
(home-page "https://github.com/google/protobuf")
@@ -51,17 +54,55 @@ yet extensible format. Google uses Protocol Buffers for almost all of its
internal RPC protocols and file formats.")
(license bsd-3)))
+;; XXX Remove this old version when no other packages depend on it.
+(define-public protobuf-2
+ (package (inherit protobuf)
+ (version "2.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/protobuf/releases/"
+ "download/v" version "/protobuf-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))))
+
+(define-public protobuf-c
+ (package
+ (name "protobuf-c")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/protobuf-c/protobuf-c/"
+ "releases/download/v" version
+ "/protobuf-c-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18aj4xfv26zjmj44zbb01wk90jl7y4aj5xvbzz4gg748kdxavjax"))))
+ (build-system gnu-build-system)
+ (inputs `(("protobuf" ,protobuf)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/protobuf-c/protobuf-c")
+ (synopsis "Protocol Buffers implementation in C")
+ (description
+ "This is protobuf-c, a C implementation of the Google Protocol Buffers
+data serialization format. It includes @code{libprotobuf-c}, a pure C library
+that implements protobuf encoding and decoding, and @code{protoc-c}, a code
+generator that converts Protocol Buffer @code{.proto} files to C descriptor
+code.")
+ (license bsd-2)))
+
(define-public python-protobuf
(package
(name "python-protobuf")
- (version "3.0.0")
+ (version "3.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "1xbgbfg4g43bihkyw1a2giqa2gxmqc5wkh0fzqcb90qi1z1hpi7c"))))
+ "0x33xz85cy5ilg1n2rn92l4qwlcw25vzysx2ldv7k625yjg600pg"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))