summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 4978ea7290..9c125dcc4f 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -66,14 +66,15 @@ line syntax.")
"1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'patch-test
- (lambda _
- (substitute* "test-poptrc.in"
- (("/bin/echo") (which "echo")))
- (substitute* "testit.sh" ; don't expect old libtool names
- (("lt-test1") "test1")))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-test
+ (lambda _
+ (substitute* "test-poptrc.in"
+ (("/bin/echo") (which "echo")))
+ (substitute* "testit.sh" ; don't expect old libtool names
+ (("lt-test1") "test1"))
+ #t)))))
(home-page "http://rpm5.org/files/popt/")
(synopsis "Command line option parsing library")
(description