summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 121ffab767..a28cb31e5c 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -50,19 +50,10 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:))
-(define gd-for-php
- (package
- (inherit gd)
- (source (origin
- (inherit (package-source gd))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"
- "gd-CVE-2018-5711.patch"))))))
-
(define-public php
(package
(name "php")
- (version "7.2.8")
+ (version "7.2.12")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -70,7 +61,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "03zv1y8ygzsir60617hinpji3f4irk79zbp3ar1b8zcapq40gfjk"))
+ "1qbz2j9kzqxxp0mmx02zavvz20ji7izqdnri25g1mrwyhz60974q"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -185,6 +176,11 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
+ ;; The expected output is slightly different from what is given,
+ ;; in a section that's not related to the actual test
+ (substitute* "sapi/cli/tests/upload_2G.phpt"
+ (("Test\\\\n") "Test\n\n"))
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
@@ -236,6 +232,7 @@
;; but with different error messages.
;; Expects "illegal character", instead gets "unknown error (84)".
"ext/iconv/tests/bug52211.phpt"
+ "ext/iconv/tests/bug60494.phpt"
;; Expects "wrong charset", gets unknown error (22).
"ext/iconv/tests/iconv_mime_decode_variation3.phpt"
"ext/iconv/tests/iconv_strlen_error2.phpt"
@@ -311,7 +308,7 @@
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
("freetype" ,freetype)
- ("gd" ,gd-for-php)
+ ("gd" ,gd)
("gdbm" ,gdbm)
("glibc" ,glibc)
("gmp" ,gmp)