summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index db7a9f9d45..9410d1761d 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -69,14 +69,14 @@
(define-public libraw
(package
(name "libraw")
- (version "0.19.0")
+ (version "0.19.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.libraw.org/data/LibRaw-"
version ".tar.gz"))
(sha256
(base32
- "0nfj7s7qmgfy1cl8s3ck7dxjvprfq5glfi6iidmvmy8r7gl52gz8"))))
+ "1xjyw4n9gfr2r637pjbpbi3h98h9mdjn61b0hsxwqynq2vdij452"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -131,14 +131,14 @@ data as produced by digital cameras.")
(define-public libgphoto2
(package
(name "libgphoto2")
- (version "2.5.19")
+ (version "2.5.21")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gphoto/libgphoto/"
version "/libgphoto2-" version ".tar.bz2"))
(sha256
(base32
- "0qrcc6kajbfb237paxrl904vvwl7hd8mnqvjw00j6m5qwd93wlk2"))))
+ "1ccb8idjkv19p9zxg6hh8y6vbgs8flpnh550lq6a8cmga8d2nmy5"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
@@ -206,7 +206,7 @@ MTP, and much more.")
(define-public perl-image-exiftool
(package
(name "perl-image-exiftool")
- (version "11.01")
+ (version "11.11")
(source (origin
(method url-fetch)
(uri (string-append
@@ -214,7 +214,7 @@ MTP, and much more.")
version ".tar.gz"))
(sha256
(base32
- "175w34n73mypdpbaqj2vgqsfp59yvfrn8k7zmx4cawnp895bypvh"))))
+ "1szg1k82nz88pp5n7lg71ja7q3hh5i5f9bcbb7m482dwrmsywkp6"))))
(build-system perl-build-system)
(arguments
'(#:phases
@@ -227,7 +227,8 @@ MTP, and much more.")
(pm (find-files out "^ExifTool\\.pm$"))
(lib (dirname (dirname (car pm)))))
(wrap-program (string-append out "/bin/exiftool")
- `("PERL5LIB" prefix (,lib)))))))))
+ `("PERL5LIB" prefix (,lib)))
+ #t))))))
(home-page "https://metacpan.org/release/Image-ExifTool")
(synopsis "Program and Perl library to manipulate EXIF and other metadata")
(description "This package provides the @code{exiftool} command and the
@@ -422,7 +423,7 @@ and enhance them.")
(define-public hugin
(package
(name "hugin")
- (version "2016.2.0")
+ (version "2018.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
@@ -430,7 +431,7 @@ and enhance them.")
"/hugin-" version ".tar.bz2"))
(sha256
(base32
- "058zd63vx29yrx2pphbbll7kzcxkai22q26lpw13rn4lvp41pasl"))))
+ "1jv5wpqbq49fhbl5g521g1qxhdm1rm7acxd18fr3n3n5d830vbyk"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gnu-gettext)