summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm124
1 files changed, 55 insertions, 69 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6a59e6bf86..3cae8dfa8f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Coypright © 2016 ng0 <ng0@libertad.pw>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
@@ -51,16 +51,16 @@
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
(package
(name "perl")
- (replacement perl/fixed)
- (version "5.24.0")
+ (version "5.26.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/src/5.0/perl-"
version ".tar.gz"))
(sha256
(base32
- "00jj8zr8fnihrxxhl8h936ssczv5x86qb618yz1ig40d1rp0qhvy"))
+ "0zxn9hd7mqgq06ikyi6k70ngbvjf01z1paw0jd25byyl0rlwdrzb"))
(patches (search-patches
+ "perl-file-path-CVE-2017-6512.patch"
"perl-no-sys-dirs.patch"
"perl-autosplit-default-time.patch"
"perl-deterministic-ordering.patch"
@@ -148,17 +148,6 @@
(home-page "http://www.perl.org/")
(license gpl1+))) ; or "Artistic"
-(define perl/fixed
- (package
- (inherit perl)
- (source
- (origin
- (inherit (package-source perl))
- (patches
- (append
- (origin-patches (package-source perl))
- (search-patches "perl-file-path-CVE-2017-6512.patch")))))))
-
(define-public perl-algorithm-c3
(package
(name "perl-algorithm-c3")
@@ -700,15 +689,15 @@ Perl.")
(define-public perl-carp-clan
(package
(name "perl-carp-clan")
- (version "6.04")
+ (version "6.06")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/S/ST/STBEY/"
+ (uri (string-append "mirror://cpan/authors/id/K/KE/KENTNL/"
"Carp-Clan-" version ".tar.gz"))
(sha256
(base32
- "1v71k8s1pi16l5y579gnrg372c6pdvy6qqm6iddm8h1dx7n16bjl"))))
+ "1m6902n6s627nsvyn2vyrk29q7lh6808hsdk7ka5cirm27vchjpa"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-exception" ,perl-test-exception)))
@@ -967,15 +956,15 @@ to the calling program.")
(define-public perl-class-inspector
(package
(name "perl-class-inspector")
- (version "1.28")
+ (version "1.31")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/P/PL/PLICEASE/"
"Class-Inspector-" version ".tar.gz"))
(sha256
(base32
- "04iij8dbcgaim7g109frpyf7mh4ydsd8zh53r53chk0zxnivg91w"))))
+ "1sqfjgzxx1f951fykc6vgfvys4j8rxaw2zf3jq26yrvs3ygn8pq6"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/Class-Inspector")
(synopsis "Get information about a class and its structure")
@@ -1207,15 +1196,15 @@ as defined by two typical specimens of Perl coders.")
(define-public perl-config-any
(package
(name "perl-config-any")
- (version "0.24")
+ (version "0.32")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/B/BR/BRICAS/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Config-Any-" version ".tar.gz"))
(sha256
(base32
- "06n6jn3q3xhk57icwip0ihzqixxav6sgp6rrb35hahj1z748y3vi"))))
+ "0l31sg7dwh4dwwnql42hp7arkhcm15bhsgfg4i6xvbjzy9f2mnk8"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-module-pluggable" ,perl-module-pluggable)))
@@ -2169,14 +2158,14 @@ This module parses and emits such dates.")
(define-public perl-datetime-format-w3cdtf
(package
(name "perl-datetime-format-w3cdtf")
- (version "0.06")
+ (version "0.07")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/G/GW/GWILLIAMS/"
"DateTime-Format-W3CDTF-" version ".tar.gz"))
(sha256
(base32
- "0ymxizwd2zfx8b4bmrmv4k439qwfwf2522jrvn4hlay5v6z459dr"))))
+ "0s32lb1k80p3b3sb7w234zgxnrmadrwbcg41lhaal7dz3dk2p839"))))
(build-system perl-build-system)
(inputs
`(("perl-datetime" ,perl-datetime)))
@@ -2372,7 +2361,7 @@ providing a simple interface to this data.")
(define-public perl-devel-stacktrace-ashtml
(package
(name "perl-devel-stacktrace-ashtml")
- (version "0.14")
+ (version "0.15")
(source
(origin
(method url-fetch)
@@ -2380,7 +2369,7 @@ providing a simple interface to this data.")
"Devel-StackTrace-AsHTML-" version ".tar.gz"))
(sha256
(base32
- "0yl296y0qfwybwjgqjzd4j2w2bj5a2nz342qqgxchnf5bqynl1c9"))))
+ "0iri5nb2lb76qv5l9z0vjpfrq5j2fyclkd64kh020bvy37idp0v2"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-devel-stacktrace" ,perl-devel-stacktrace)))
@@ -2396,7 +2385,7 @@ each stack frame.")
(define-public perl-devel-symdump
(package
(name "perl-devel-symdump")
- (version "2.17")
+ (version "2.18")
(source
(origin
(method url-fetch)
@@ -2404,7 +2393,7 @@ each stack frame.")
"Devel-Symdump-" version ".tar.gz"))
(sha256
(base32
- "0qkfjk7bm7jwn9d9qaldg298zvkqh2f19fgvfh5j1rp66mwzql1c"))))
+ "1h3n0w23camhj20a97nw7v40rqa7xcxx8vkn2qjjlngm0yhq2vw2"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/Devel-Symdump")
(synopsis "Dump symbol names or the symbol table")
@@ -2926,15 +2915,15 @@ directories.")
(define-public perl-file-find-rule-perl
(package
(name "perl-file-find-rule-perl")
- (version "1.13")
+ (version "1.15")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"File-Find-Rule-Perl-" version ".tar.gz"))
(sha256
(base32
- "0xi4ppqr6r57l5xlkwxpvkvpb9p7dvz053d76v2m9pwdfxqb5v6j"))))
+ "19iy8spzrvh71x33b5yi16wjw5jjvs12jvjj0f7f3370hqzl6j4s"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-file-find-rule" ,perl-file-find-rule)
@@ -2973,19 +2962,18 @@ provide a quick dropin when such functionality is needed.")
(define-public perl-file-homedir
(package
(name "perl-file-homedir")
- (version "1.00")
+ (version "1.002")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/"
"File-HomeDir-" version ".tar.gz"))
(sha256
(base32
- "0hvihydd0y4gdxafi8dpybk9ll8q35bz5ycibfic0gh92cslzfc5"))))
+ "0x62hn8rc7ninf9nlp69h61yh21g4cbq2g81sh64cf2ify2hqk7b"))))
(build-system perl-build-system)
(propagated-inputs
- `(("perl-file-which" ,perl-file-which)
- ("perl-file-temp" ,perl-file-temp)))
+ `(("perl-file-which" ,perl-file-which)))
(arguments `(#:tests? #f)) ;Not appropriate for chroot
(home-page "http://search.cpan.org/dist/File-HomeDir")
(synopsis "Find your home and other directories on any platform")
@@ -3077,15 +3065,15 @@ matching a regular expression.")
(define-public perl-file-remove
(package
(name "perl-file-remove")
- (version "1.52")
+ (version "1.57")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/S/SH/SHLOMIF/"
"File-Remove-" version ".tar.gz"))
(sha256
(base32
- "1p8bal9qhwkjbghivxn1d5m3qdj2qwm1agrjbmakm6la9dbxqm21"))))
+ "1b814lw181kkqh6c1n4p2zlzzsq6ic5pfpr831nphf2w2rhcvgmk"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/File-Remove")
(synopsis "Remove files and directories in Perl")
@@ -4066,14 +4054,14 @@ the argument to the CACHESIZE parameter, will be cached.")
(define-public perl-mime-charset
(package
(name "perl-mime-charset")
- (version "1.012")
+ (version "1.012.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/N/NE/NEZUMI/"
"MIME-Charset-" version ".tar.gz"))
(sha256
(base32
- "1kfc5p4g1x9c0ffhg125wvhravcviny3alwrgnhnrm2a33ad3rff"))))
+ "04qxgcg9mvia121i3zcqxgp20y0d9kg0qv6hddk93ian0af7g347"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/MIME-Charset")
(synopsis "Charset information for MIME messages")
@@ -4130,17 +4118,16 @@ file names are added for you.")
(define-public perl-modern-perl
(package
(name "perl-modern-perl")
- (version "1.20150127")
+ (version "1.20170117")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://cpan/authors/id/C/CH/CHROMATIC/Modern-Perl-"
- version
- ".tar.gz"))
+ version ".tar.gz"))
(sha256
(base32
- "0iv2crfxl3xh6mq36g1gv9fr8iqq3kpbj8afxy5qi60hh7v3xhcl"))))
+ "0a1n9c04zhs1a1km1zi0d1hj78d10qv3bhxr4bdi4chnc4saiwjx"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)))
@@ -4384,7 +4371,7 @@ from Moose::Conflicts and moose-outdated.")
(define-public perl-module-scandeps
(package
(name "perl-module-scandeps")
- (version "1.18")
+ (version "1.24")
(source
(origin
(method url-fetch)
@@ -4392,7 +4379,7 @@ from Moose::Conflicts and moose-outdated.")
"Module-ScanDeps-" version ".tar.gz"))
(sha256
(base32
- "17mbyqwd8c20nqw01hjshl524vkw8pq6y2lwndmw36xkqr945npz"))))
+ "0s6cj90ckhy351gql52ksh4ms1x8piv26iadl09fcpzkx7j0srw9"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-requires" ,perl-test-requires)))
@@ -5087,15 +5074,15 @@ and libraries based on OpenSSL.")
(define-public perl-mro-compat
(package
(name "perl-mro-compat")
- (version "0.12")
+ (version "0.13")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/B/BO/BOBTFISH/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"MRO-Compat-" version ".tar.gz"))
(sha256
(base32
- "1mhma2g83ih9f8nkmg2k9l0x6izhhbb6k5lli4rpllxad4wbk9dv"))))
+ "1y547lr6zccf7919vx01v22zsajy528psanhg5aqschrrin3nb4a"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/MRO-Compat")
(synopsis "MRO interface compatibility for Perls < 5.9.5")
@@ -6610,7 +6597,7 @@ contents of a file is equal to a particular string.")
(define-public perl-test-harness
(package
(name "perl-test-harness")
- (version "3.36")
+ (version "3.39")
(source
(origin
(method url-fetch)
@@ -6618,7 +6605,7 @@ contents of a file is equal to a particular string.")
"Test-Harness-" version ".tar.gz"))
(sha256
(base32
- "0gmnjss0hjkyiwvgby50nl5nzv254pn7fjqqdysjil21n09nymp7"))))
+ "0chiqnzmna2mglm37nzxvn9qhq2j31iwz3i9isqjs7bf3k449gb9"))))
(build-system perl-build-system)
(arguments
`(#:phases (alist-cons-before
@@ -6640,15 +6627,15 @@ automatically aggregated and output to STDOUT.")
(define-public perl-test-leaktrace
(package
(name "perl-test-leaktrace")
- (version "0.15")
+ (version "0.16")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/G/GF/GFUJI/"
+ (uri (string-append "mirror://cpan/authors/id/L/LE/LEEJO/"
"Test-LeakTrace-" version ".tar.gz"))
(sha256
(base32
- "0pp6ip012c474ibw0mwd7jgig34gf98bb8xlqk4wdvw1d65vbf7g"))))
+ "00z4hcjra5nk700f3fgpy8fs036d7ry7glpn8g3wh7jzj7nrw22z"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/Test-LeakTrace")
(synopsis "Traces memory leaks in Perl")
@@ -6940,25 +6927,24 @@ If this fails, then rather than failing tests this skips all tests.")
(define-public perl-test-script
(package
(name "perl-test-script")
- (version "1.07")
+ (version "1.20")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/P/PL/PLICEASE/"
"Test-Script-" version ".tar.gz"))
(sha256
(base32
- "15pb4zzsnm33msc1syhig2bk05xqc0pckmfyahdwbd177bj5w7p2"))))
+ "1msavbi6przkxq3npm90nv925v58iym9jrk677wn46x19whwzwzm"))))
(build-system perl-build-system)
(propagated-inputs
- `(("probe-perl" ,perl-probe-perl)
- ("ipc-run3" ,perl-ipc-run3)))
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-probe-perl" ,perl-probe-perl)))
(synopsis "Basic cross-platform tests for scripts")
(description
"The intent of the Test::Script module is to provide a series of basic
tests for 80% of the testing you will need to do for scripts in the script (or
bin as is also commonly used) paths of your Perl distribution.")
- (home-page (string-append "http://search.cpan.org/~adamk/"
- "Test-Script-" version))
+ (home-page "http://search.cpan.org/dist/Test-Script")
(license (package-license perl))))
(define-public perl-test-sharedfork
@@ -7789,14 +7775,14 @@ defined by Annex #11 is used to determine breaking positions.")
(define-public perl-unicode-utf8
(package
(name "perl-unicode-utf8")
- (version "0.60")
+ (version "0.62")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/C/CH/CHANSEN/"
"Unicode-UTF8-" version ".tar.gz"))
(sha256
(base32
- "1g3fp47slsk7wbz3189kpg342lfs7lpsy570jxnx7s9v59dg5k7n"))))
+ "1xnhazbdvpyfpnxd90krzhxkvabf8fa2ji6xzlrf75j6nz8251zs"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)
@@ -7972,17 +7958,17 @@ and memory overhead.")
(define-public perl-parse-yapp
(package
(name "perl-parse-yapp")
- (version "1.05")
+ (version "1.2")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/F/FD/FDESAR/Parse-Yapp-"
+ "mirror://cpan/authors/id/W/WB/WBRASWELL/Parse-Yapp-"
version
".tar.gz"))
(sha256
(base32
- "0azjqqf4m7nkfgmmj4q77vy9sdgg01wn8xxv40bq3pis93xnr2i2"))))
+ "16p4qgqg28cy76ylcf4wq1r693gqpx8xq0w32b3564i67h49zljb"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/Parse-Yapp")
(synopsis "Generate and use LALR parsers")