summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm29
1 files changed, 26 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0e63aa943e..6ca62aa2ae 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2758,9 +2758,9 @@ versa using either JSON::XS or JSON::PP.")
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)
- ("perl-test-requires", perl-test-requires)
- ("perl-test-warnings", perl-test-warnings)
- ("perl-test-without-module", perl-test-without-module)))
+ ("perl-test-requires" ,perl-test-requires)
+ ("perl-test-warnings" ,perl-test-warnings)
+ ("perl-test-without-module" ,perl-test-without-module)))
(propagated-inputs
`(("perl-namespace-clean" ,perl-namespace-clean)))
(home-page "http://search.cpan.org/dist/JSON-Any")
@@ -6277,4 +6277,27 @@ really be high enough to warrant the use of a keyword, and the size so small
such that being individual extensions would be wasteful.")
(license (package-license perl))))
+(define-public perl-shell-command
+ (package
+ (name "perl-shell-command")
+ (version "0.06")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/F/FL/FLORA/Shell-Command-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1lgc2rb3b5a4lxvbq0cbg08qk0n2i88srxbsz93bwi3razpxxr7k"))))
+ (build-system perl-build-system)
+ (home-page
+ "http://search.cpan.org/dist/Shell-Command")
+ (synopsis
+ "Cross-platform functions emulating common shell commands")
+ (description
+ "Shell::Command is a thin wrapper around ExtUtils::Command.")
+ (license (package-license perl))))
+
;;; END: Core module overrides