summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6ca62aa2ae..d67870f462 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -37,6 +37,7 @@
(define-public perl
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
(package
+ (replacement perl-fixed)
(name "perl")
(version "5.22.1")
(source (origin
@@ -114,6 +115,28 @@
(home-page "http://www.perl.org/")
(license gpl1+))) ; or "Artistic"
+(define perl-fixed
+ (package
+ (inherit perl)
+ (replacement #f)
+ (source
+ (let ((name "perl") (version "5.22.1"))
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.cpan.org/src/5.0/perl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "09wg24w5syyafyv87l6z8pxwz4bjgcdj996bx5844k6m9445sirb"))
+ (patches (map search-patch
+ '("perl-no-sys-dirs.patch"
+ "perl-autosplit-default-time.patch"
+ "perl-source-date-epoch.patch"
+ "perl-deterministic-ordering.patch"
+ "perl-no-build-time.patch"
+ "perl-CVE-2015-8607.patch"
+ "perl-CVE-2016-2381.patch"))))))))
+
(define-public perl-algorithm-c3
(package
(name "perl-algorithm-c3")