summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm198
1 files changed, 179 insertions, 19 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f92d50290e..6069413264 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -1065,7 +1065,7 @@ to the calling program.")
(define-public perl-class-inspector
(package
(name "perl-class-inspector")
- (version "1.32")
+ (version "1.36")
(source
(origin
(method url-fetch)
@@ -1073,7 +1073,7 @@ to the calling program.")
"Class-Inspector-" version ".tar.gz"))
(sha256
(base32
- "0d85rihxahdvhj8cysqrgg0kbmcqghz5hgy41dbkxr1qaf5xrynf"))))
+ "0kk900bp8iq7bw5jyllfb31gvf93mmp24n4x90j7qs3jlhimsafc"))))
(build-system perl-build-system)
(home-page "https://metacpan.org/release/Class-Inspector")
(synopsis "Get information about a class and its structure")
@@ -1611,14 +1611,14 @@ CPAN::Meta object are present.")
(define-public perl-cpanel-json-xs
(package
(name "perl-cpanel-json-xs")
- (version "4.15")
+ (version "4.17")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
"Cpanel-JSON-XS-" version ".tar.gz"))
(sha256
- (base32 "1695408fj6jjx6dv5082hhxg5am480x1nz7s0f355npv0wm776wx"))))
+ (base32 "1yq6hwd6hayqrhaa2h90svqqvsc28k0g4bdip5nyxgm9r93sx07s"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-common-sense" ,perl-common-sense)))
@@ -1768,18 +1768,18 @@ input.")
(define-public perl-data-compare
(package
(name "perl-data-compare")
- (version "1.25")
+ (version "1.27")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/D/DC/DCANTRELL/"
"Data-Compare-" version ".tar.gz"))
(sha256
- (base32
- "0wzasidg9yjcfsi2gdiaw6726ikqda7n24n0v2ngpaazakdkcjqx"))))
+ (base32 "1gg8rqbv3x6a1lrpabv6vnlab53zxmpwz2ygad9fcx4gygqj12l1"))))
(build-system perl-build-system)
(propagated-inputs
- `(("perl-file-find-rule" ,perl-file-find-rule)))
+ `(("perl-clone" ,perl-clone)
+ ("perl-file-find-rule" ,perl-file-find-rule)))
(home-page "https://metacpan.org/release/Data-Compare")
(synopsis "Compare Perl data structures")
(description "This module compares arbitrary data structures to see if
@@ -2268,14 +2268,14 @@ time before its creation (in 1582).")
(define-public perl-datetime-calendar-julian
(package
(name "perl-datetime-calendar-julian")
- (version "0.100")
+ (version "0.102")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/W/WY/WYANT/"
"DateTime-Calendar-Julian-" version ".tar.gz"))
(sha256
- (base32 "0gbw7rh706qk5jlmmz3yzsm0ilzp39kyar28g4j6d57my8cwaipx"))))
+ (base32 "0j95dhma66spjyb04zi6rwy7l33hibnrx02mn0znd9m89aiq52s6"))))
(build-system perl-build-system)
;; Only needed for tests
(native-inputs
@@ -2700,17 +2700,17 @@ particular command is available.")
(define-public perl-devel-checklib
(package
(name "perl-devel-checklib")
- (version "1.13")
+ (version "1.14")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MATTN/Devel-CheckLib-"
version ".tar.gz"))
(sha256
- (base32 "1a19qkwxwz3wqb16cdabymfbf9kiydiifw90nd5srpq5hy8gvb94"))))
+ (base32 "15621qh5gaan1sgmk9y9svl70nm8viw17x5h1kf0zknkk8lmw77j"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-io-captureoutput" ,perl-io-captureoutput)
+ `(("perl-capture-tiny" ,perl-capture-tiny)
("perl-mock-config" ,perl-mock-config)))
(home-page "https://metacpan.org/release/Devel-CheckLib")
(synopsis "Check that a library is available")
@@ -3320,6 +3320,33 @@ By itself it is not a particularly interesting module by any measure, however
it ties together a family of modern toolchain modules.")
(license (package-license perl))))
+(define-public perl-extutils-cppguess
+ (package
+ (name "perl-extutils-cppguess")
+ (version "0.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ET/ETJ/ExtUtils-CppGuess-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0q9ynigk600fv95xac6aslrg2k19m6qbzf5hqfsnall8113r3gqj"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)))
+ (home-page
+ "https://metacpan.org/release/ExtUtils-CppGuess")
+ (synopsis "Tool for guessing C++ compiler and flags")
+ (description "ExtUtils::CppGuess attempts to guess the C++ compiler that
+is compatible with the C compiler used to build perl.")
+ (license (package-license perl))))
+
(define-public perl-extutils-depends
(package
(name "perl-extutils-depends")
@@ -3385,6 +3412,29 @@ C code in your Perl programs, there isn't a clear method to compile standard,
self-contained C libraries. This module main goal is to help in that task.")
(license (package-license perl))))
+(define-public perl-extutils-parsexs
+ (package
+ (name "perl-extutils-parsexs")
+ (version "3.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "077fqiyabydm8j34wxzxwxskyidh8nmwq9gskaxai8kq298z1pj1"))))
+ (build-system perl-build-system)
+ (home-page
+ "https://metacpan.org/release/ExtUtils-ParseXS")
+ (synopsis "Module to convert Perl XS code into C code")
+ (description "The package contains the ExtUtils::ParseXS module to
+convert Perl XS code into C code, the ExtUtils::Typemaps module to
+handle Perl/XS typemap files, and their submodules.")
+ (license (package-license perl))))
+
(define-public perl-extutils-pkgconfig
(package
(name "perl-extutils-pkgconfig")
@@ -3408,6 +3458,56 @@ of perl extensions which bind libraries that @command{pkg-config} knows.
It is really just boilerplate code that you would have written yourself.")
(license lgpl2.1+)))
+(define-public perl-extutils-typemaps-default
+ (package
+ (name "perl-extutils-typemaps-default")
+ (version "1.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SM/SMUELLER/ExtUtils-Typemaps-Default-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1phmha0ks95kvzl00r1kgnd5hvg7qb1q9jmzjmw01p5zgs1zbyix"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "https://metacpan.org/release/ExtUtils-Typemaps-Default")
+ (synopsis "Set of useful typemaps")
+ (description "The package provides a number of useful typemaps as
+submodules of ExtUtils::Typemaps.")
+ (license (package-license perl))))
+
+(define-public perl-extutils-xspp
+ (package
+ (name "perl-extutils-xspp")
+ (version "0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SM/SMUELLER/ExtUtils-XSpp-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1zx84f93lkymqz7qa4d63gzlnhnkxm5i3gvsrwkvvqr9cxjasxli"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-base" ,perl-test-base)
+ ("perl-test-differences" ,perl-test-differences)))
+ (home-page
+ "https://metacpan.org/release/ExtUtils-XSpp")
+ (synopsis "XS for C++")
+ (description "This module implements the Perl foreign function
+interface XS for C++; it is a thin layer over plain XS.")
+ (license (package-license perl))))
+
(define-public perl-file-changenotify
(package
(name "perl-file-changenotify")
@@ -3442,7 +3542,7 @@ changes made to any file.")
(define-public perl-file-configdir
(package
(name "perl-file-configdir")
- (version "0.018")
+ (version "0.021")
(source
(origin
(method url-fetch)
@@ -3450,11 +3550,12 @@ changes made to any file.")
"File-ConfigDir-" version ".tar.gz"))
(sha256
(base32
- "1xpzrlya0gskk7lm6gppyfwbk0swv0n6ssgp629575dk5l49z2rf"))))
+ "1ihlhdbwaybyj3xqfxpx4ii0ypa41907b6zdh94rvr4wyqa5lh3b"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-file-homedir" ,perl-file-homedir)
- ("perl-list-moreutils" ,perl-list-moreutils)))
+ ("perl-list-moreutils" ,perl-list-moreutils)
+ ("perl-test-without-module" ,perl-test-without-module)))
(home-page "https://metacpan.org/release/File-ConfigDir")
(synopsis "Get directories of configuration files")
(description "This module is a helper for installing, reading and finding
@@ -5245,6 +5346,36 @@ replacement. Whereas Module::Build has over 6,700 lines of code; this module
has less than 120, yet supports the features needed by most distributions.")
(license (package-license perl))))
+(define-public perl-module-build-withxspp
+ (package
+ (name "perl-module-build-withxspp")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SM/SMUELLER/Module-Build-WithXSpp-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0d39fjg9c0n820bk3fb50vvlwhdny4hdl69xmlyzql5xzp4cicsk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-extutils-cppguess" ,perl-extutils-cppguess)
+ ("perl-extutils-xspp" ,perl-extutils-xspp)
+ ("perl-module-build" ,perl-module-build)))
+ (home-page
+ "https://metacpan.org/release/Module-Build-WithXSpp")
+ (synopsis
+ "The module provides an XS++ enhanced flavour of Module::Build")
+ (description "This subclass of Module::Build adds some tools and
+processes to make it easier to use for wrapping C++ using XS++
+(ExtUtils::XSpp).")
+ (license (package-license perl))))
+
(define-public perl-module-build-xsutil
(package
(name "perl-module-build-xsutil")
@@ -6341,6 +6472,35 @@ takes additional parameters and uses @code{Getopt::Long::Descriptive} to
generate a command line tool.")
(license (package-license perl))))
+(define-public perl-moox-strictconstructor
+ (package
+ (name "perl-moox-strictconstructor")
+ (version "0.010")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/H/HA/HARTZELL/MooX-StrictConstructor-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0vvjgz7xbfmf69yav7sxsxmvklqv835xvh7h47w0apxmlkm9fjgr"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-fatal" ,perl-test-fatal)))
+ (propagated-inputs
+ `(("perl-class-method-modifiers" ,perl-class-method-modifiers)
+ ("perl-moo" ,perl-moo)
+ ("perl-strictures" ,perl-strictures)))
+ (home-page "https://metacpan.org/release/MooX-StrictConstructor")
+ (synopsis "Make Moo-based object constructors blow up on unknown attributes")
+ (description
+ "Loading @code{MooX::StrictConstructor} makes your constructors \"strict\".
+If your constructor is called with an attribute init argument that your class
+does not declare, then it dies.")
+ (license perl-license)))
+
(define-public perl-moox-types-mooselike
(package
(name "perl-moox-types-mooselike")
@@ -9053,14 +9213,14 @@ variable conform.")
(define-public perl-type-tiny
(package
(name "perl-type-tiny")
- (version "1.004004")
+ (version "1.006000")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/T/TO/TOBYINK/"
"Type-Tiny-" version ".tar.gz"))
(sha256
- (base32 "1gk2f0zs2xq99nqn6wcgvl8l9qlq2cnab2lk7l08kpac03m824h8"))))
+ (base32 "007xsx78cnjillbny7x9sjn1w6z8m22fmksmay710jhbvw9h19nm"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-warnings" ,perl-test-warnings)))