summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm190
1 files changed, 190 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4b3ce036e2..d6a75506ec 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -53,6 +53,7 @@
#:use-module (guix build-system perl)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gd)
#:use-module (gnu packages less)
@@ -386,6 +387,49 @@ functions. The password hashing function is implemented in XS with a
pure Perl backup version for systems that cannot handle XS.")
(license gpl2+)))
+(define-public perl-authen-passphrase
+ (package
+ (name "perl-authen-passphrase")
+ (version "0.008")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/Z/ZE/ZEFRAM/Authen-Passphrase-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qq4krap687rxf6xr31bg5nj5dqmm1frcm7fq249v1bxc4h4bnsm"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (propagated-inputs
+ `(("perl-authen-dechpwd" ,perl-authen-dechpwd)
+ ("perl-crypt-des" ,perl-crypt-des)
+ ("perl-crypt-eksblowfish" ,perl-crypt-eksblowfish)
+ ("perl-crypt-mysql" ,perl-crypt-mysql)
+ ("perl-crypt-passwdmd5" ,perl-crypt-passwdmd5)
+ ("perl-crypt-unixcrypt_xs" ,perl-crypt-unixcrypt_xs)
+ ("perl-data-entropy" ,perl-data-entropy)
+ ("perl-digest-md4" ,perl-digest-md4)
+ ("perl-module-runtime" ,perl-module-runtime)
+ ("perl-params-classify" ,perl-params-classify)))
+ (home-page "https://metacpan.org/release/Authen-Passphrase")
+ (synopsis "Hashed passwords/passphrases as objects")
+ (description "@code{Authen-Passphrase} is the base class for a
+system of objects that encapsulate passphrases. An object of this
+type is a passphrase recogniser; its job is to recognise whether an
+offered passphrase is the right one. For security such passphrase
+recognisers usually do not themselves know the passphrase they are
+looking for; they can merely recognise it when they see it. There are
+many schemes in use to achieve this effect and the intent of this
+class is to provide a consistent interface to them all. In addition
+to the base class, this module also contains implementations of
+several specific passphrase schemes.")
+ (license perl-license)))
+
(define-public perl-autovivification
(package
(name "perl-autovivification")
@@ -1849,6 +1893,55 @@ CPAN::Meta object are present.")
versa.")
(license (package-license perl))))
+(define-public perl-crypt-cbc
+ (package
+ (name "perl-crypt-cbc")
+ (version "2.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LD/LDS/Crypt-CBC-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ig698lmpjz7fslnznxm0609lvlnvf4f3s370082nzycnqhxww3a"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-crypt-rijndael" ,perl-crypt-rijndael)))
+ (home-page "https://metacpan.org/release/Crypt-CBC")
+ (synopsis "Encrypt Data with Cipher Block Chaining Mode")
+ (description "@code{Crypt::CBC} is a Perl-only implementation of
+the cryptographic Cipher Block Chaining (CBC) mode. In combination
+with a block cipher such as @code{Crypt::Rijndael} you can encrypt and
+decrypt messages of arbitrarily long length. The encrypted messages
+are compatible with the encryption format used by SSLeay.")
+ (license perl-license)))
+
+(define-public perl-crypt-des
+ (package
+ (name "perl-crypt-des")
+ (version "2.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DP/DPARIS/Crypt-DES-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rypxlhpd1jc0c327aghgl9y6ls47drmpvn0a40b4k3vhfsypc9d"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-crypt-cbc" ,perl-crypt-cbc)))
+ (home-page "https://metacpan.org/release/Crypt-DES")
+ (synopsis "DES encryption module")
+ (description "@code{Crypt::DES} is an XS-based implementation of
+the DES cryptography algorithm. The module implements the
+@code{Crypt::CBC} interface which has blocksize, keysize, encrypt and
+decrypt functions.")
+ (license bsd-3)))
+
(define-public perl-crypt-eksblowfish
(package
(name "perl-crypt-eksblowfish")
@@ -1883,6 +1976,57 @@ also includes an implementation of @code{bcrypt}, the Unix crypt()
password hashing algorithm based on Eksblowfish.")
(license perl-license)))
+(define-public perl-crypt-mysql
+ (package
+ (name "perl-crypt-mysql")
+ (version "0.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/I/IK/IKEBE/Crypt-MySQL-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qyx6ha13r0rh80ldv5wy2bq2pa74igwh8817xlapsfgxymdzswk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-dbd-mysql" ,perl-dbd-mysql)))
+ (propagated-inputs
+ `(("perl-digest-sha1" ,perl-digest-sha1)))
+ (home-page "https://metacpan.org/release/Crypt-MySQL")
+ (synopsis "Emulate the MySQL PASSWORD() function")
+ (description "@code{Crypt::MySQL} emulates the MySQL PASSWORD()
+function. The module does not depend on an interface to the MySQL
+database server. This enables the comparison of encrypted passwords
+without the need for a real MySQL environment.")
+ (license perl-license)))
+
+(define-public perl-crypt-passwdmd5
+ (package
+ (name "perl-crypt-passwdmd5")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RS/RSAVAGE/Crypt-PasswdMD5-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0j0r74f18nk63phddzqbf7wqma2ci4p4bxvrwrxsy0aklbp6lzdp"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page "https://metacpan.org/release/Crypt-PasswdMD5")
+ (synopsis "Interoperable MD5-based crypt() functions")
+ (description "@code{Crypt::PasswdMD5} provides various
+crypt()-compatible interfaces to the MD5-based crypt() function found
+in various *nixes. It is based on the implementation found on FreeBSD
+2.2.[56]-RELEASE.")
+ (license perl-license)))
+
(define-public perl-crypt-randpasswd
(package
(name "perl-crypt-randpasswd")
@@ -1957,6 +2101,29 @@ supported encryption modes are:
(description "A pure Perl implementation of the RC4 algorithm.")
(license (package-license perl))))
+(define-public perl-crypt-unixcrypt_xs
+ (package
+ (name "perl-crypt-unixcrypt_xs")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BO/BORISZ/Crypt-UnixCrypt_XS-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ajg3x6kwxy4x9p3nw1j36qjxpjvdpi9wkca5gfd86y9q8939sv2"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Crypt-UnixCrypt_XS")
+ (synopsis "XS interface for a portable traditional crypt function")
+ (description "@code{Crypt::UnixCrypt_XS} implements the DES-based
+Unix @code{crypt} function. For those who need to construct
+non-standard variants of @code{crypt}, the various building blocks
+used in @code{crypt} are also supplied separately.")
+ ;; Files in the 'fcrypt' directory are covered by a BSD licence.
+ (license (list perl-license bsd-3))))
+
(define-public perl-cwd-guard
(package
(name "perl-cwd-guard")
@@ -3413,6 +3580,29 @@ for CRC-CCITT, CRC-16 and CRC-32.")
interface for the RFC 2104 HMAC mechanism.")
(license (package-license perl))))
+(define-public perl-digest-md4
+ (package
+ (name "perl-digest-md4")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MI/MIKEM/DigestMD4/Digest-MD4-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19ma1hmvgiznq95ngzvm6v4dfxc9zmi69k8iyfcg6w14lfxi0lb6"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Digest-MD4")
+ (synopsis "Interface to the MD4 Algorithm")
+ (description "The @code{Digest::MD4} module allows you to use the
+RSA Data Security Inc.@: MD4 Message Digest algorithm from within Perl
+programs. The algorithm takes as input a message of arbitrary length
+and produces as output a 128-bit \"fingerprint\" or \"message digest\"
+of the input. MD4 is described in RFC 1320.")
+ (license perl-license)))
+
(define-public perl-digest-md5
(package
(name "perl-digest-md5")