summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cmake-curl-certificates.patch40
-rw-r--r--gnu/packages/patches/tipp10-fix-compiling.patch3
-rw-r--r--gnu/packages/patches/weechat-python.patch40
3 files changed, 41 insertions, 42 deletions
diff --git a/gnu/packages/patches/cmake-curl-certificates.patch b/gnu/packages/patches/cmake-curl-certificates.patch
new file mode 100644
index 0000000000..36252083f8
--- /dev/null
+++ b/gnu/packages/patches/cmake-curl-certificates.patch
@@ -0,0 +1,40 @@
+By default commands such as "ctest" would not look for certificates
+at all: <https://issues.guix.gnu.org/issue/37371>.
+
+This changes CMake such that commands honor SSL_CERT_FILE and SSL_CERT_DIR
+as well as /etc/ssl/certs.
+
+--- cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:27:36.926907260 +0200
++++ cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:52:35.475903919 +0200
+@@ -4,11 +4,8 @@
+
+ #include "cmThirdParty.h"
+
+-#if !defined(CMAKE_USE_SYSTEM_CURL) && !defined(_WIN32) && \
+- !defined(__APPLE__) && !defined(CURL_CA_BUNDLE) && !defined(CURL_CA_PATH)
+ # define CMAKE_FIND_CAFILE
+ # include "cmSystemTools.h"
+-#endif
+
+ // curl versions before 7.21.5 did not provide this error code
+ #if defined(LIBCURL_VERSION_NUM) && LIBCURL_VERSION_NUM < 0x071505
+@@ -29,6 +26,19 @@ std::string cmCurlSetCAInfo(::CURL* curl
+ ::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile);
+ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
+ }
++
++ /* Honor the usual environment variables. */
++ else if (cmSystemTools::GetEnv("SSL_CERT_FILE", e)) {
++ ::CURLcode res =
++ ::curl_easy_setopt(curl, CURLOPT_CAINFO, e.c_str());
++ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
++ }
++ else if (cmSystemTools::GetEnv("SSL_CERT_DIR", e)) {
++ ::CURLcode res =
++ ::curl_easy_setopt(curl, CURLOPT_CAPATH, e.c_str());
++ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
++ }
++
+ #ifdef CMAKE_FIND_CAFILE
+ # define CMAKE_CAFILE_FEDORA "/etc/pki/tls/certs/ca-bundle.crt"
+ else if (cmSystemTools::FileExists(CMAKE_CAFILE_FEDORA, true)) {
diff --git a/gnu/packages/patches/tipp10-fix-compiling.patch b/gnu/packages/patches/tipp10-fix-compiling.patch
index 4c206d4d83..3a34a98b22 100644
--- a/gnu/packages/patches/tipp10-fix-compiling.patch
+++ b/gnu/packages/patches/tipp10-fix-compiling.patch
@@ -204,8 +204,7 @@ https://sources.debian.net/data/main/t/tipp10/2.1.0-2/debian/patches/0001-FixCom
Name=TIPP10
Comment=Touch Typing Tutor
Comment[de]=10-Finger-Schreibtrainer
--Exec=tipp10
-+Exec=/usr/bin/tipp10
+ Exec=tipp10
Icon=tipp10.png
Terminal=false
Type=Application
diff --git a/gnu/packages/patches/weechat-python.patch b/gnu/packages/patches/weechat-python.patch
deleted file mode 100644
index 8182636ecb..0000000000
--- a/gnu/packages/patches/weechat-python.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Get Python LDFLAGS from 'pkg-config'.
-
-The other approach is more complex and gets it wrong: it returns
-"-L/path/to/python/lib/python-2.7.10/lib/python2.7/config -lpython -lwhatever";
-since that config/ sub-directory contains libpython2.7.a, we end up
-statically linking Python in Weechat's python.so, which we do not want.
-
---- weechat-1.3/configure.ac 2015-08-16 08:27:07.000000000 +0200
-+++ weechat-1.3/configure.ac 2015-11-29 18:18:52.975197048 +0100
-@@ -535,29 +535,7 @@ if test "x$enable_python" = "xyes" ; the
- if test -r "$PYTHON_INCLUDE/Python.h"; then
- PYTHON_CFLAGS="-I$PYTHON_INCLUDE"
- AC_MSG_RESULT(found)
-- PYTHON_LIB=`$PYTHON -c "import sys, distutils.sysconfig; sys.stdout.write(distutils.sysconfig.get_config_var('LIBPL'))"`
-- PYTHON_LFLAGS="-lpython$PYTHON_VERSION "`$PYTHON -c "import sys, distutils.sysconfig; sys.stdout.write(distutils.sysconfig.get_config_var('LIBS')+' '+distutils.sysconfig.get_config_var('SYSLIBS')+' '+distutils.sysconfig.get_config_var('LINKFORSHARED'))"`
-- AC_MSG_CHECKING(for Python library)
-- if test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.so"; then
-- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
-- AC_MSG_RESULT(found)
-- elif test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.a"; then
-- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
-- AC_MSG_RESULT(found)
-- elif test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.dll.a"; then
-- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
-- AC_MSG_RESULT(found)
-- elif test -r "$PYTHON_SYSPREFIX/lib/libpython$PYTHON_VERSION.so"; then
-- PYTHON_LFLAGS="-L$PYTHON_SYSPREFIX/lib/ $PYTHON_LFLAGS"
-- AC_MSG_RESULT(found)
-- else
-- AC_MSG_WARN([
--*** Python library couldn't be found on your system.
--*** Try to install it with your software package manager.
--*** WeeChat will be built without Python support.])
-- enable_python="no"
-- not_found="$not_found python"
-- fi
-+ PYTHON_LFLAGS=`pkg-config python2 --libs`
- else
- AC_MSG_WARN([
- *** Python header files couldn't be found on your system.