summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/wicd-get-selected-profile-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/wicd-get-selected-profile-fix.patch')
-rw-r--r--gnu/packages/patches/wicd-get-selected-profile-fix.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/wicd-get-selected-profile-fix.patch b/gnu/packages/patches/wicd-get-selected-profile-fix.patch
new file mode 100644
index 0000000000..3042a87308
--- /dev/null
+++ b/gnu/packages/patches/wicd-get-selected-profile-fix.patch
@@ -0,0 +1,16 @@
+Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2
+
+--- wicd-1.7.3/curses/wicd-curses.py 2014-12-21 16:57:33 +0000
++++ wicd-1.7.3/curses/wicd-curses.py 2015-02-24 23:41:01 +0000
+@@ -532,7 +532,10 @@
+ def get_selected_profile(self):
+ """Get the selected wired profile"""
+ loc = self.get_focus()[1]
+- return self.theList[loc]
++ if len(self.theList) > loc:
++ return self.theList[loc]
++ else:
++ return self.theList[-1]
+
+
+ class AdHocDialog(Dialog2):