summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/texlive-bin-poppler-0.86.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/texlive-bin-poppler-0.86.patch')
-rw-r--r--gnu/packages/patches/texlive-bin-poppler-0.86.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/texlive-bin-poppler-0.86.patch b/gnu/packages/patches/texlive-bin-poppler-0.86.patch
new file mode 100644
index 0000000000..b1adca657b
--- /dev/null
+++ b/gnu/packages/patches/texlive-bin-poppler-0.86.patch
@@ -0,0 +1,17 @@
+Fix build with Poppler 0.86 and later.
+
+Taken from Arch Linux, but adjusted to patch the versioned Poppler
+files, as upstream applies it after copying them in place.
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/texlive-poppler-0.86.patch?h=packages/texlive-bin
+
+--- a/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:11:35.102711802 +0000
++++ b/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:13:13.057420111 +0000
+@@ -757,7 +757,7 @@
+ if (page_name) {
+ // get page by name
+ GString name(page_name);
+- LinkDest *link = pdf_doc->doc->findDest(&name);
++ LinkDest *link = pdf_doc->doc->findDest(&name).get();
+ if (link == 0 || !link->isOk())
+ pdftex_fail("PDF inclusion: invalid destination <%s>", page_name);
+ Ref ref = link->getPageRef();