summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-dendropy-exclude-failing-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-dendropy-exclude-failing-tests.patch')
-rw-r--r--gnu/packages/patches/python-dendropy-exclude-failing-tests.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-dendropy-exclude-failing-tests.patch b/gnu/packages/patches/python-dendropy-exclude-failing-tests.patch
new file mode 100644
index 0000000000..288a58b06f
--- /dev/null
+++ b/gnu/packages/patches/python-dendropy-exclude-failing-tests.patch
@@ -0,0 +1,21 @@
+diff --git a/dendropy/test/test_phylogenetic_distance_matrix.py b/dendropy/test/test_phylogenetic_distance_matrix.py
+index 10c05f5..a18ba52 100644
+--- a/dendropy/test/test_phylogenetic_distance_matrix.py
++++ b/dendropy/test/test_phylogenetic_distance_matrix.py
+@@ -793,7 +793,7 @@ class PdmUpgmaTree(PdmTreeChecker, unittest.TestCase):
+ expected_tree=expected_tree)
+
+ class NodeToNodeDistancesTest(unittest.TestCase):
+-
++ @unittest.expectedFailure
+ def test_distances(self):
+ ## get distances from ape
+ # library(ape)
+@@ -825,6 +825,7 @@ class NodeToNodeDistancesTest(unittest.TestCase):
+ e = reference_table[nd1.label, nd2.label]
+ self.assertAlmostEqual(d, e)
+
++ @unittest.expectedFailure
+ def test_mrca(self):
+ test_runs = [
+ "hiv1.newick",