summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch')
-rw-r--r--gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
new file mode 100644
index 0000000000..432cafc162
--- /dev/null
+++ b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
@@ -0,0 +1,26 @@
+This following patch was originally found at the debian mingw-w64 team's
+mingw-w64 repo located here:
+https://salsa.debian.org/mingw-w64-team/mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
+
+Description: Specify dlltool's temp prefix
+Author: Stephen Kitt <steve@sk2.org>
+
+By default dlltool uses its pid for the object files it generates.
+Enforcing its temp prefix allows the files it generates to be
+reproducible.
+
+--- a/mingw-w64-crt/Makefile.am
++++ b/mingw-w64-crt/Makefile.am
+@@ -36,7 +36,7 @@
+ DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
+ DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
+ else
+- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
++ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
+ DLLTOOLFLAGSARM32=-m arm
+ DLLTOOLFLAGSARM64=-m arm64
+ DLLTOOLFLAGS32=--as-flags=--32 -m i386