summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lsh-no-root-login.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/lsh-no-root-login.patch')
-rw-r--r--gnu/packages/patches/lsh-no-root-login.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/lsh-no-root-login.patch b/gnu/packages/patches/lsh-no-root-login.patch
new file mode 100644
index 0000000000..9dd81de3fb
--- /dev/null
+++ b/gnu/packages/patches/lsh-no-root-login.patch
@@ -0,0 +1,16 @@
+Correctly handle the `--no-root-login' option.
+
+--- lsh-2.0.4/src/lshd.c 2006-05-01 13:47:44.000000000 +0200
++++ lsh-2.0.4/src/lshd.c 2009-09-08 12:20:36.000000000 +0200
+@@ -758,6 +758,10 @@ main_argp_parser(int key, char *arg, str
+ self->allow_root = 1;
+ break;
+
++ case OPT_NO_ROOT_LOGIN:
++ self->allow_root = 0;
++ break;
++
+ case OPT_KERBEROS_PASSWD:
+ self->pw_helper = PATH_KERBEROS_HELPER;
+ break;
+