summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libreoffice-poppler-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libreoffice-poppler-compat.patch')
-rw-r--r--gnu/packages/patches/libreoffice-poppler-compat.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/libreoffice-poppler-compat.patch b/gnu/packages/patches/libreoffice-poppler-compat.patch
new file mode 100644
index 0000000000..8dc0b60a12
--- /dev/null
+++ b/gnu/packages/patches/libreoffice-poppler-compat.patch
@@ -0,0 +1,19 @@
+Fix type mismatch with Poppler 0.86.
+
+Taken from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/libreoffice-poppler-0.86.patch?h=packages/libreoffice-fresh
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -563,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
+ if (!(pAction && pAction->getKind() == actionURI))
+ return;
+
+-#if POPPLER_CHECK_VERSION(0, 72, 0)
++#if POPPLER_CHECK_VERSION(0, 86, 0)
++ const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
++#elif POPPLER_CHECK_VERSION(0, 72, 0)
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
+ #else
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();