summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/hubbub-sort-entities.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/hubbub-sort-entities.patch')
-rw-r--r--gnu/packages/patches/hubbub-sort-entities.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/hubbub-sort-entities.patch b/gnu/packages/patches/hubbub-sort-entities.patch
new file mode 100644
index 0000000000..012e3c3022
--- /dev/null
+++ b/gnu/packages/patches/hubbub-sort-entities.patch
@@ -0,0 +1,13 @@
+Traverse the entities hash's keys in sorted order to ensure reproducibility.
+
+--- libhubbub-0.3.3/build/make-entities.pl
++++ libhubbub-0.3.3/build/make-entities.pl
+@@ -86,7 +86,7 @@
+
+ my $trie;
+
+-foreach my $key (keys %entities) {
++foreach my $key (sort keys %entities) {
+ $trie = insert_node($trie, $key, $entities{$key});
+ }
+