summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fontconfig-hurd-path-max.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/fontconfig-hurd-path-max.patch')
-rw-r--r--gnu/packages/patches/fontconfig-hurd-path-max.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/fontconfig-hurd-path-max.patch b/gnu/packages/patches/fontconfig-hurd-path-max.patch
new file mode 100644
index 0000000000..f804e6801f
--- /dev/null
+++ b/gnu/packages/patches/fontconfig-hurd-path-max.patch
@@ -0,0 +1,17 @@
+Avoid usage of PATH_MAX.
+
+Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
+
+Index: fontconfig-2.13.1/src/fccfg.c
+===================================================================
+--- fontconfig-2.13.1.orig/src/fccfg.c
++++ fontconfig-2.13.1/src/fccfg.c
+@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
+
+ if (n)
+ {
+- FcChar8 buf[PATH_MAX];
++ FcChar8 buf[FC_PATH_MAX];
+ ssize_t len;
+
+ if (sysroot)