summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/beets-werkzeug-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/beets-werkzeug-compat.patch')
-rw-r--r--gnu/packages/patches/beets-werkzeug-compat.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/beets-werkzeug-compat.patch b/gnu/packages/patches/beets-werkzeug-compat.patch
new file mode 100644
index 0000000000..1a91c3a3f9
--- /dev/null
+++ b/gnu/packages/patches/beets-werkzeug-compat.patch
@@ -0,0 +1,18 @@
+Be compatible with python-werkzeug 1.0.0.
+
+Taken from upstream:
+https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
+
+diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
+index f53fb3a954..21ff5d94ed 100644
+--- a/beetsplug/web/__init__.py
++++ b/beetsplug/web/__init__.py
+@@ -169,7 +169,7 @@ def to_python(self, value):
+ return ids
+
+ def to_url(self, value):
+- return ','.join(value)
++ return ','.join(str(v) for v in value)
+
+
+ class QueryConverter(PathConverter):