summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 923122903e..011cf594d1 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages suckless)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
@@ -94,7 +96,7 @@ human.")
(define-public keepassxc
(package
(name "keepassxc")
- (version "2.3.1")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
@@ -103,7 +105,7 @@ human.")
version "-src.tar.xz"))
(sha256
(base32
- "1gdrbpzwbs56anc3k5vklvcackcn214pc8gm5xh5zcymsi8q4zff"))))
+ "1m8alsp39vk21zgcvy5zswk0dc1xmajbwnccg7n0lndsi7pqbzyg"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DWITH_XC_NETWORKING=YES"
@@ -659,3 +661,30 @@ Upstream development seems to have stopped. It is therefore recommended
to use a different password manager.")
(home-page "https://als.regnet.cz/fpm2/")
(license license:gpl2+)))
+
+(define-public pass-rotate
+ (package
+ (name "pass-rotate")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/SirCmpwn/pass-rotate/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1svm5nj8bczv2dg8lh2zqqhbsrljqsw9680r03qwgl9vlci90210"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-docopt" ,python-docopt)
+ ("python-html5lib" ,python-html5lib)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/SirCmpwn/pass-rotate")
+ (synopsis "Rotate password on online services")
+ (description "pass-rotate is a command line utility and python library for
+rotating passwords on various web services. It makes it easier to rotate your
+passwords, one at a time or in bulk, when security events or routine upkeep of
+your online accounts makes it necessary.")
+ (license license:expat)))